Table of Contents

1 Introduction ........................................................................................................................................... 5

2 Getting Started ........................................................................................................................................ 7
   2.1 Installation .................................................................................................................................. 7
   2.2 Starting OneStep Accounting ................................................................................................. 7
   2.3 Opening The Database File ..................................................................................................... 7
   2.4 Exploring the Sample Company ............................................................................................ 8
   2.5 Logging In .................................................................................................................................. 8
   2.6 Entering The Registration Key ............................................................................................... 8
   2.7 Working With OneStep ........................................................................................................... 9

3 Setting Up OneStep For Your Business ................................................................................................. 17
   3.1 Preparing For Conversion To OneStep .................................................................................. 17
   3.2 Creating A New Company ....................................................................................................... 17
   3.3 Setting Up Company Details .................................................................................................. 18
   3.4 Setting Up Employee Details .................................................................................................. 19
   3.5 Setting Up Credit Terms .......................................................................................................... 19
   3.6 Setting Up General Ledger Accounts (a.k.a Chart of Accounts) ........................................... 20
   3.7 Setting Up Payment Methods ................................................................................................ 24
   3.8 Setting Up Tax Items ............................................................................................................... 25
   3.9 Setting Up Preferences ........................................................................................................... 26
   3.10 Setting Up Items ...................................................................................................................... 29
   3.11 Setting Up Customers ............................................................................................................. 33
   3.12 Setting Up Vendors .................................................................................................................. 33
   3.13 Setting Up Opening Balances ............................................................................................... 34
   3.14 Setting Up Outstanding Sales Invoices And Credit Memos For Opening ......................... 36
   3.15 Setting Up Outstanding Purchase Invoices And Debit Memos For Opening ..................... 37
   3.16 Setting Up Document References ....................................................................................... 39
   3.17 Entering Historical Transactions ......................................................................................... 39
   3.18 Customizing The Printouts Of Your Business Documents ................................................... 39

4 Sales Processing ..................................................................................................................................... 45
   4.1 Quotation (Available In Professional Edition Only) ............................................................... 45
   4.2 Sales Order (Available In Professional Edition Only) ............................................................ 48
   4.3 Delivery Order (Available In Professional Edition Only) ....................................................... 51
   4.4 Sales Invoice ................................................................................................................................ 53
   4.5 Credit Memo ............................................................................................................................ 56
   4.6 Cash Sales ................................................................................................................................... 59
   4.7 Customer ................................................................................................................................... 61

5 Purchase Processing .............................................................................................................................. 66
   5.1 Purchase Order (Available In Professional Edition Only) ........................................................ 66
   5.2 Goods Received Note (Available In Professional Edition Only) ............................................. 69
   5.3 Purchase Invoice ....................................................................................................................... 71
   5.4 Debit Memo .................................................................................................................................. 74
   5.5 Cash Purchase ............................................................................................................................ 76
   5.6 Vendor ........................................................................................................................................ 79

6 Cash Management .................................................................................................................................. 83
   6.1 Cash Receipt ............................................................................................................................... 83
   6.2 Cash Disbursement ................................................................................................................... 86

7 Items Management .................................................................................................................................. 91
   7.1 Item .............................................................................................................................................. 91
   7.2 Inventory Adjustment ............................................................................................................... 93
   7.3 Build / Unbuild Assembly ......................................................................................................... 95
1 Introduction

OneStep Accounting is an integrated accounting plus business management software for small and medium-sized businesses. It assists you in managing your business by automating many accounting functions transparently. Just fill in familiar on screen forms such as invoices and cash receipts, all the accounts like customer accounts, sales accounts, inventory accounts, etc. will be updated automatically.

OneStep Accounting Version 4.0 is available in two editions:

1. OneStep Accounting Standard Edition and

Below is a table listing the key features available in these two editions

<table>
<thead>
<tr>
<th>Feature</th>
<th>Standard Edition</th>
<th>Professional Edition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Customer Master</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Sales Quotation</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Sales Order</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Delivery Order</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Credit Memo</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Sales Invoice</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Cash Sales</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Purchase</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Vendor Master</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Purchase Order</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Goods Received Note</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Debit Memo</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Purchase Invoice</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Cash Purchase</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>General Ledger</td>
<td></td>
<td></td>
</tr>
<tr>
<td>General Journal</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>General Ledger Account</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Bank Reconciliation</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Cash Management</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cash Receipt</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Cash Disbursement</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Item Management</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Item Master</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Inventory Adjustment</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Build / Unbuild Assembly</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Price Group</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Price Table</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Reports</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Feature</td>
<td>Standard Edition</td>
<td>Professional Edition</td>
</tr>
<tr>
<td>-------------------------</td>
<td>------------------</td>
<td>----------------------</td>
</tr>
<tr>
<td>Trial Balance</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Balance Sheet</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Profit &amp; Loss Statement</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Taxable Journal</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Transaction Log</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>AR &amp; AP Aging</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Report Explorer</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>User Administration</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Login Protection</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>User Account &amp; User Group</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Function Access Control</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Others</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Multi-User Support</td>
<td></td>
<td>✓</td>
</tr>
</tbody>
</table>
2 Getting Started

2.1 Installation

Before installing OneStep, please check that your personal computer meets the following requirements:

a) Operating System: Window 98 or higher.
b) Memory: 128 MB or higher.
c) Disk Space: at least 30 MB of free space.

After ensuring that the above requirements are met, you can follow the steps below to install OneStep.

Step 1 – Download Installation File

Download the OneStepStandard.zip (if you are installing OneStep Accounting Standard Edition) or OneStepPro.zip (if you are installing OneStep Accounting Professional Edition) from our website www.enablecomputing.com to your computer and unzip the file to a temporary directory. Two directories, the 'OneStep' and the 'Interbase' directories, will then be created in your temporary directory.

Step 2 – Install Interbase (Skip this step if you are installing OneStep Professional Edition for additional users.)

Run the setup.exe program in the 'Interbase' directory to install the interbase server. The setup.exe will lead you through the installation.

Step 3 – Install OneStep Accounting

Run the setup.exe program in the 'OneStep' directory to install the OneStep Accounting software. The setup.exe will lead you through the installation.

2.2 Starting OneStep Accounting

After Interbase and OneStep are installed, you can then start running OneStep by clicking on the Start menu at the lower-left corner of your window screen and choosing Program→OneStep Accounting→OneStep Accounting.

2.3 Opening The Database File

OneStep can be used to manage more than one company. The data of each company is stored as a separate data file. So before you can start working on any of the companies, you are required to open the company's data file by selecting File→Open Company and then selecting the data file of the required company.
OneStep Accounting will remember the data file you last opened and reopen this data file automatically the next time you run it.

2.4 Exploring the Sample Company

Come with OneStep installation is a sample company that you can use to try out the functionality of OneStep. Assuming that you have installed OneStep in the default directory, the sample data file – 'sample.gdb', can be found in your 'C:\Program Files\Enable Computing\OneStep\Data' directory.

2.5 Logging In

After the selected data file has been opened, log in to the system by selecting File ➔ Login and then keying in the user id and password when prompted.

The user id and password for the sample company and any newly created company is 'super' with no password (i.e. Leave the password field blank).

2.6 Entering The Registration Key

You need to obtain a registration key for OneStep if you decided to use it in your business. Before a valid registration key is entered into OneStep, OneStep is running in its evaluation mode which allows up to only 50 transactions for each business document type. If you intend to use OneStep Standard Edition, you can obtain a free registration key by filling up the registration form on our website – www.enablecomputing.com. If you intend to use OneStep Professional Edition, you will need to purchase the registration key through our website.

Once you have obtained a valid registration key, you can then enter the registration key into OneStep. To enter the registration key, select File ➔ Registration from the menu bar and then add the registration key at the registration dialog.

If you are running OneStep Professional and have purchased additional simultaneous client licenses for multiusers access, you should also enter the client license registration keys here.
2.7 Working With OneStep

OneStep uses a set of common screen displays for most of its functions. Once you understand these screen displays, you should be able to move around in OneStep easily.

The sections below describe the common displays you would find in OneStep.

2.7.1 Main Window

OneStep’s main window is the first window you will see. It consists of the title bar, the menu bar, the tool bar, the client window and the status bar. The menu and tool bars allow you to access the various records and functions (e.g. Quotation, Order, Invoice, Customer, Vendor, Item, etc.) in OneStep. The client window is the area where all other forms would appear in. For example, if you select a customer record, the form for you to view and edit the record would appear in the client window. You can open more than one form in the client window. The status bar shows the current status of OneStep.

If you are using the Standard Edition, the main window will look like the one below instead.
2.7.2 List Forms

List forms are used in OneStep to show a collection of records of the same type. For example, a customer list form will show you the list of customers you have entered into the system.

Different components on the List Form are described below.

Selection Bar

The selection bar provides you with functions to search for a record and to limit the records (filtering) displayed in the list. To search for a particular record, just type in the first few letters in the search box and the program will scroll through the list to find the matching record for you. The filter function allows you to restrict the record listing to those that you are interested. See the section on Filter Form for more information.

List

The list shows a collection of records that satisfy the criteria set in the filter. You can select a record from the list before selecting a command at the bottom of the form. Double clicking on a record in the list will automatically invoke the Edit command.

Command Buttons

At the bottom of the form are buttons that you can use to invoke commands. Buttons found on a typical list form are:

- **New**: Click this button to create a new record.
- **Edit**: Click this button to edit or view the highlighted record.
- **Delete**: Click this button to delete the highlighted record.
- **Refresh**: Click this button to refresh the list.
- **Close**: Click this button to close the form.

There may be other buttons on the form based on the type of record the list is displaying.

Navigator

The navigator provides you with a way to move from record to record.
2.7.3 Filter Forms

When you click on the filter button of a list form, you call up a filter form. This filter form allows you to set the selection criteria for restricting the records appear in the list form. This is useful when you have many records and you are only interested in those that meet certain criteria.

After you have defined a filter, you can save the filter for use at a later time. If you save a filter with its name set to ‘Default’, OneStep will use this filter automatically the next time you open the list form.

Filter Name: The name of the filter. When a filter is save, the filter name is used as the file name.

Criteria Panel

The criteria panel contains a list of fields and the fields' criteria settings. Below describes the various columns in the panel.

Field: The name of a record field.

On: When this check box is checked, the condition set against the field will be used.

Condition: Together with Value 1 and Value 2, they form the selection criteria against the field.

Value 1, Value 2: Together with Condition value, they form the selection criteria against the field. Value 2 is only used when you are defining a range.

Command Buttons
At the bottom of the form are buttons that you can use to invoke commands.

**Save**: Click this button to save the filter.

**Load**: Click this button to load a filter.

**Clear**: Click this button to clear all the conditions set in the filter.

**Delete**: Click this button to delete a filter you have previously saved.

**Ok**: Click the button to apply the filter to the list.

**Cancel**: Cancel all changes and close the form.

### 2.7.4 Record Forms

Whenever you need to work on any business records, you work with the data of the record presented in a record form. Below describes the common components that appear in a record form.

#### Data Panel

This is the place where the data of a record is displayed and edited. The data that would appear in this panel depends on the associated record type. For instance, a customer record would have a very different set of data from that of an invoice record.

#### Command Buttons

At the bottom of the form are buttons that you can use to invoke commands. Buttons common to a typical record form are:

**Ok**: Click this button to save all the changes you have made to the record.

**Cancel**: Click this button to cancel the changes you have made.

**Close**: Click this button to close the form.

There maybe other buttons on the form based on the type of record displaying in the form.
Navigator

The navigator provides you with the functions to move from record to record. Also on the navigator are speed buttons for you to add, delete and refresh a record.

2.7.5 Account Journal Form

The Account Journal lists all the transactions of a particular account over a period of time you specified. You can bring up the account journal by right-clicking on the account of interest at the list forms of Customers, Vendors, Items and General Ledger Accounts, and then selecting the Account Journal command from the pop-up menu.

Below describes the components on the account journal form.

**Selection Fields**

**Dates:** This field lets you select the date range of the transactions that you are interested in.

**From:** The start date of the date range.

**To:** The ending date of the date range.

**Data Fields**

**Date:** The date of the transaction.
**Source:** The source document’s type of the transaction.

**Ref:** The source document’s reference number.

**Description:** The description of the transaction.

**Remark:** For bank account only. This field holds the payment reference number like the cheque number.

**Amount:** The change in dollar amount introduced by the transaction to the account. Appears only when the “In Credit and Debit” checkbox is unchecked.

**Balance:** The balance of the account after the transaction.

**Qty:** The change in quantity introduced by the transaction to the account. Only applies to item account.

**Qty balance:** The quantity balance of the account after the transaction. Only applies to item account.

**Credit:** The credit amount introduced by the transaction. Appears only when the “In Credit and Debit” checkbox is checked.

**Debit:** The debit amount introduced by the transaction. Appears only when the “Show Credit and Debit” checkbox is checked.

**Clr:** Indicates whether the amount has been reconciled (a.k.a. cleared). Only applies to bank account.

**Command Buttons**

**Print:** Click this button to print the journal.

**Refresh:** Click this button to re-fetch the data.

**Close:** Click this button to close the form.

**Others→Print Preview:** Click the button to preview the printing of the journal.

**Others→Select Report Form:** Click this button to bring up the select report form dialog.

**Others**

**In Credit and Debit:** Check this to show credit and debit values.

### 2.7.6 Print Account Journal Form

Another way to print the journal of your accounts is to use the Print Account Journal function. This function lets you print the journals of multiple accounts at one go. You can bring up the Print Account Journal Form by selecting the relevant command from the Customer, Vendor, Item and General Ledger Accounts list form.

Below describes the components on the Print Account Journal form.
Selection Bar

The selection bar provides you with functions to search for a record and to limit the records (filtering) displayed in the list. To search for a particular record just type in the first few letters in the search box and OneStep will scroll through the list to find the matching record for you. The filter function allows you to restrict the record listing to those that you are interested. See the previous section on Filter Form for more information.

Data Fields

**Name:** The name of the account.

**Balance:** The balance of the account.

**Selected:** Check this if you want to print the journal of this account.

Command Buttons

**Select All:** Click this button to select all the accounts in the list.

**Unselect All:** Click this button to unselect all the accounts in the list.

**Print:** Click this button to print the journals of the selected accounts.

**Close:** Click this button to close the form.

2.7.7 Select Report Form Dialog

If you want to change the printout format of the business documents (like invoices, cash receipts, etc.) that you are printing, you can use the Select Report Form. From the Select Report Form, you can change the default printout format, select a different printout format to be used for printing, and bring up the report designer to change the printout format.

Below describes the components on the select report form dialog.
Data Fields

Name: The name of the report form.

Default: This field indicates the default report form.

Command Buttons

Set As Default: Click this button to set the highlighted report form as the default report form.

New: Click this button to use the report designer to create a new report form.

Edit: Click this button to use the report designer to edit the selected report form.

Delete: Click this button to delete the selected report form.

Print: Click this button to print the business document using the report form selected.

Preview: Click this button to preview the printout of the business document using the report form selected.

Close: Click this button to close the dialog window.

2.7.8 Important Key Sequences

Followings are some key sequences you will need to know in order to work effectively in OneStep. Note, a plus sign ‘+’ indicates that you are to press the first key and hold it down while pressing the second key.

<Tab>: To move to the next field.

<Shift + Tab>: To move to previous field.

<Alt + Down Arrow>: To drop down the lookup list of a combo box or the calendar of a date edit box.

<Insert>: To insert a line to a list.

<Ctrl + Delete>: To delete a line from a list.
3 Setting Up OneStep For Your Business

3.1 Preparing For Conversion To OneStep

There are some preparations needed for converting to OneStep.

3.1.1 Deciding On A Start Date

The first thing to do when planning to move to OneStep is to decide on a start date. The start date is simply the date at which you begin entering your daily business records. Below are some pointers on choosing a start date.

➢ The start date need not be the same as your conversion date and it can be a date in the past. For example, it could be 1st April 2003, even though you are doing your conversion in June 2003.

➢ As data before the start date will not be available to you in the new system, you have to decide on the amount of historical data that you want to keep. The closer your start date is to the present day, the less historical data you will need to enter.

➢ If in doubt, ask your accountant for advice.

3.1.2 Deciding On When To Do Your Conversion

As it takes time for you to do the conversion (because you need to enter all the necessary data into the system), it will be better to choose a time when you are not so busy.

3.1.3 Working Out Your Chart of Accounts (a.k.a. General Ledger Accounts)

If you are converting from an existing accounting system, you probably already have a Chart of Accounts. If you are setting up a new company and you have not yet had any Chart of Accounts, you can consult your accountant for recommendations. OneStep allows you to add, modify or delete an account any time you need to, so you need only to work out the essential accounts as a start and add on new accounts as and when the needs arise.

3.1.4 Gathering Your Records

Once you have decided on the start date, you can start gathering all the business records dating back to the start date. Take note that not all the business records are needed to be entered into the system; some business records that do not directly affect your accounts can be selectively left out. For instance, records like the Sales Quotations or Sales Orders that you have already issued the corresponding Sales Invoice can be left out if you do not need to refer to them anymore.

3.1.5 Working out the Opening Balances

You need to work out the opening balances for your general ledger, customer, vendor and item accounts as of the start date. Opening balances are the amounts your customers owe you, the amounts you owe others, the amounts and quantity in your inventory, your checking or savings account balances, etc. as of the start date.

After you have done the above preparation, you can follow the steps in the following sections to set up OneStep for your company.

3.2 Creating A New Company

To create a new data file for your company, select File→New Company from the menu bar.
When prompted, enter a name for the data file (for example, c:\enable computing\onestep\data\abc, assuming abc is your company name) where your company's data will be stored and click Ok.

Click Yes when prompted to open the new data file.

**Please Note**: The size of your database is limited only by the size of your hard disk; therefore it would be good if you have at least 100Mb of free disk space on your hard disk.

After the new company has been created, select File → Login to log in. The user id to use is 'super' with no password.

### 3.3 Setting Up Company Details

To set up your company details, select Admin → Company from either the menu or the tool bar.

Enter the followings:

- Your company’s name.
- Your company’s address.
- The address where you want your vendor to ship the goods to.
- Your company’s tax registration or ID number.
3.4 Setting Up Employee Details

If you want to tag the name of your sales representatives to your sales documents like sales order, sales invoice, etc. then you would need to set up the employee records.

Please Note: You can skip this part if you do not need to tag a sales representative to your sales documents.

To add an employee record, select Admin→Employee from either the menu or the tool bar.

Click on the New button of the Employee List Form to add a new employee record.

Enter the following into the employee record:

➢ Name of the employee.
➢ Initials of the employee.
➢ Employee’s phone number.
➢ Set Active to checked.

3.5 Setting Up Credit Terms

To set up your credit terms, select Admin→Terms from either the menu or the tool bar.
Click on the New button of the Terms List Form to add a new credit term.

Below shows examples of 2 different types of credit terms you may want to create.

**Cash on Delivery (COD)**

Use this credit term if you want your customers to pay immediately upon the delivery of goods.

Enter the followings:
- Name of the credit term.
- Description.
- Select 'Cash on delivery' as type.

**Due in Number of Days**

Use this to give your customers to purchase on credit term which is due in X number of days after you billed him/her.

Also under this credit term you are allowed to specify the discount that the customer would enjoy should he/she pay up early within a specified number of days.

Enter the followings:
- Name of the credit term.
- Description.
- Select 'Due in number of days' as type.
- Discount percentage for early payment.
- The number of days by which payment must be received to qualify for the discount.
- The number of days on which payment is due.

### 3.6 Setting Up General Ledger Accounts (a.k.a Chart of Accounts)

The next step is to create the general ledger accounts needed to help you keep track of the company’s financial positions
When a new company is created, OneStep automatically adds the top-level accounts, namely Assets, Liabilities, Equity, Income, Cost of Sales, Expenses, Other Income, Other Expenses and Income Tax Expense accounts, into the company’s chart of accounts.

Below shows an example of a typical chart of accounts.

<table>
<thead>
<tr>
<th>Balance Sheet Accounts</th>
<th>Profit &amp; Loss Accounts</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Assets</strong></td>
<td><strong>Income</strong></td>
</tr>
<tr>
<td>Fixed Assets</td>
<td>Sales</td>
</tr>
<tr>
<td>Office Equipment</td>
<td>Sales Discount</td>
</tr>
<tr>
<td>Office Equipment (Cost)</td>
<td>Cost Of Sales</td>
</tr>
<tr>
<td>Office Equipment (Accu. Depn)</td>
<td>Cost of Goods Sold</td>
</tr>
<tr>
<td><strong>Furniture &amp; Fittings</strong></td>
<td>Purchase Discount</td>
</tr>
<tr>
<td>Furniture &amp; Fittings (Cost)</td>
<td>Expenses</td>
</tr>
<tr>
<td>Furniture &amp; Fittings (Accu. Depn)</td>
<td>Depreciation</td>
</tr>
<tr>
<td><strong>Current Assets</strong></td>
<td><strong>Other Income</strong></td>
</tr>
<tr>
<td>Cash on Hand</td>
<td>Medical</td>
</tr>
<tr>
<td>ABC Bank</td>
<td>Phone &amp; Fax</td>
</tr>
<tr>
<td>Trade Debtors</td>
<td>Rental</td>
</tr>
<tr>
<td>GST Receivable</td>
<td>Transports</td>
</tr>
<tr>
<td>Inventory</td>
<td>Utilities</td>
</tr>
<tr>
<td><strong>Liabilities</strong></td>
<td><strong>Other Expenses</strong></td>
</tr>
<tr>
<td>Trade Creditors</td>
<td>Income Tax Expense</td>
</tr>
<tr>
<td>GST Payable</td>
<td></td>
</tr>
<tr>
<td><strong>Equity</strong></td>
<td></td>
</tr>
<tr>
<td>Share Capital</td>
<td></td>
</tr>
<tr>
<td>Retained Earnings</td>
<td></td>
</tr>
</tbody>
</table>

To add a general ledger account, select GL→General Ledger from either the menu or the tool bar.

Click on the New button of the General Ledger List Form to add a new general ledger account.
OneStep supports various types of accounts and they are explained below:

**Group Accounts**

Group accounts are used to group accounts of similar nature under the same heading and you will not be able to post directly to these accounts.

In our Chart of Accounts example, the Fixed Assets, Office Equipment, Furniture & Fittings, Current Assets, etc. are group accounts.

To add a group account, enter the followings:

- Name of account.
- Description of the account.
- Set ‘Is Group’ to ‘Yes’.
- Select the parent account.
- Set the position of this account as you would want it to appear under its parent account. In our example, ‘Fixed Assets’ is our first group account under Assets hence is set to 1.
- Leave the type value as is. OneStep will set it according to the parent account. In our example, since the 'Fixed Assets' group account is under the parent account Assets, it will be set to 'Asset' automatically.

**Control Accounts**

Control accounts are used in general ledger to maintain the summary of customer, vendor and item accounts.

For example, you may create a Trade Debtor account to hold the summary of all your customer accounts in your general ledger.

To add a control account, enter the followings:

- Name of account.
- Description of the account.
- Set ‘Is Group’ to ‘No’.
- Select the parent account.
- Set the position of this account as you would want it to appear under its parent account. In our example, ‘Trade Debtor’ is the third account under Current Assets hence is set to 3.
- Set type to the type of control account you want to create. For control accounts for customers, select ‘Account Receivable’. For vendors, select ‘Account Payable’. For inventory, select ‘Inventory’.
Bank Accounts

Bank accounts are accounts that may be reconciled against your bank statement.

To add a bank account, enter the followings:

➢ Name of account.
➢ Description of the account.
➢ Set ‘Is Group’ to ‘No’.
➢ Select the parent account.
➢ Set the position of this account as you would want it to appear under its parent account. In our example, ‘ABC Bank’ is the second account under Current Assets hence is set to 2.
➢ Set the type to ‘Bank’.

Normal Accounts

A normal account can be an asset, liability, equity, income, cost of sales, expense, other income or other expense account. Most of your GL accounts should be under this category.

To add a normal account, enter the followings:

➢ Name of account.
➢ Description of the account.
➢ Set ‘Is Group’ to ‘No’.
➢ Select the parent account.
➢ Set the position of this account as you would want it to appear under its parent account. In our example, ‘Cash On Hand’ is the first account under Current Assets hence is set to 1.
➢ Leave the type value as is. OneStep will set it according to the parent account. In our example, since 'Cash On Hand' account is under Current Assets which is in turn under Assets, its type value will be set to 'Asset' automatically.

The details for creating all the accounts in our Chart of Accounts' example is as follow:

<table>
<thead>
<tr>
<th>Name</th>
<th>Is Group?</th>
<th>Sub-Account of</th>
<th>Position</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed Assets</td>
<td>Yes</td>
<td>Assets</td>
<td>1</td>
<td>Asset</td>
</tr>
<tr>
<td>Office Equipment</td>
<td>Yes</td>
<td>Fixed Assets</td>
<td>1</td>
<td>Asset</td>
</tr>
<tr>
<td>Office Equipment (Cost)</td>
<td>No</td>
<td>Office Equipment</td>
<td>1</td>
<td>Asset</td>
</tr>
<tr>
<td>Office Equipment (Accu Deprn)</td>
<td>No</td>
<td>Office Equipment</td>
<td>2</td>
<td>Asset</td>
</tr>
<tr>
<td>Furniture &amp; Fittings</td>
<td>Yes</td>
<td>Fixed Assets</td>
<td>2</td>
<td>Asset</td>
</tr>
<tr>
<td>Furniture &amp; Fittings (Cost)</td>
<td>No</td>
<td>Furniture &amp; Fittings</td>
<td>1</td>
<td>Asset</td>
</tr>
<tr>
<td>Name</td>
<td>Is Group?</td>
<td>Sub-Account of</td>
<td>Position</td>
<td>Type</td>
</tr>
<tr>
<td>------------------------------------------</td>
<td>-----------</td>
<td>------------------------</td>
<td>----------</td>
<td>-------------------</td>
</tr>
<tr>
<td>Furniture &amp; Fittings (Accu. Depn)</td>
<td>No</td>
<td>Furniture &amp; Fittings</td>
<td>2</td>
<td>Asset</td>
</tr>
<tr>
<td>Current Assets</td>
<td>Yes</td>
<td>Assets</td>
<td>2</td>
<td>Asset</td>
</tr>
<tr>
<td>Cash On Hand</td>
<td>No</td>
<td>Current Assets</td>
<td>1</td>
<td>Asset</td>
</tr>
<tr>
<td>ABC On Hand</td>
<td>No</td>
<td>Current Assets</td>
<td>2</td>
<td>Bank</td>
</tr>
<tr>
<td>Trade Debtors</td>
<td>No</td>
<td>Current Assets</td>
<td>3</td>
<td>Account Receivable</td>
</tr>
<tr>
<td>GST Receivable</td>
<td>No</td>
<td>Current Assets</td>
<td>4</td>
<td>Asset</td>
</tr>
<tr>
<td>Inventory</td>
<td>No</td>
<td>Current Assets</td>
<td>5</td>
<td>Inventory</td>
</tr>
<tr>
<td>Trade Creditors</td>
<td>No</td>
<td>Liabilities</td>
<td>1</td>
<td>Account Payable</td>
</tr>
<tr>
<td>GST Payable</td>
<td>No</td>
<td>Liabilities</td>
<td>2</td>
<td>Liability</td>
</tr>
<tr>
<td>Share Capital</td>
<td>No</td>
<td>Equity</td>
<td>1</td>
<td>Equity</td>
</tr>
<tr>
<td>Retained Earnings</td>
<td>No</td>
<td>Equity</td>
<td>2</td>
<td>Equity</td>
</tr>
<tr>
<td>Sales</td>
<td>No</td>
<td>Income</td>
<td>1</td>
<td>Income</td>
</tr>
<tr>
<td>Sales Discount</td>
<td>No</td>
<td>Income</td>
<td>2</td>
<td>Income</td>
</tr>
<tr>
<td>Cost of Goods Sold</td>
<td>No</td>
<td>Cost Of Sales</td>
<td>1</td>
<td>Cost Of Sales</td>
</tr>
<tr>
<td>Purchase Discount</td>
<td>No</td>
<td>Cost Of Sales</td>
<td>2</td>
<td>Cost Of Sales</td>
</tr>
<tr>
<td>Depreciation</td>
<td>No</td>
<td>Expenses</td>
<td>1</td>
<td>Expense</td>
</tr>
<tr>
<td>Medical</td>
<td>No</td>
<td>Expenses</td>
<td>2</td>
<td>Expense</td>
</tr>
<tr>
<td>Phone &amp; Fax</td>
<td>No</td>
<td>Expenses</td>
<td>3</td>
<td>Expense</td>
</tr>
<tr>
<td>Rental</td>
<td>No</td>
<td>Expenses</td>
<td>4</td>
<td>Expense</td>
</tr>
<tr>
<td>Transports</td>
<td>No</td>
<td>Expenses</td>
<td>5</td>
<td>Expense</td>
</tr>
<tr>
<td>Utilities</td>
<td>No</td>
<td>Expenses</td>
<td>6</td>
<td>Expense</td>
</tr>
<tr>
<td>Wages</td>
<td>No</td>
<td>Expenses</td>
<td>7</td>
<td>Expense</td>
</tr>
</tbody>
</table>

### 3.7 Setting Up Payment Methods

To set up payment methods, select Admin → Payment Methods from either the menu or the tool bar.

Click on the New button of the Payment Method List Form to add a new payment method.

24 Setting Up OneStep For Your Business
Enter the followings to the payment method record:

➢ Name of the payment method.
➢ Description of the payment method.
➢ Default posting account for this payment method.

The screen shots on the right are two examples of payment method.

3.8 Setting Up Tax Items

Tax items are used when you charge or pay tax on invoices.

To set up tax items, select Item ➔ Items from either the menu or the tool bar.

Click on the New button of the Item List Form to add a new item.

Enter the followings:

➢ Name of the tax item. For example, GST, VAT, etc.
➢ Under the ‘Type’ field, select ‘Tax’.
Under the 'Item' tab:

- Description of this tax item.
- Tax rate into the percentage field.
- Check the taxable field if you want the taxed amount to be included for the computation of another tax charges.

Under the 'Account' tab:

- The posting account when a sales is made.
- The posting account when a sales returns is made.
- The posting account when a purchase is made.

Note: Sometimes you may want to create a tax item whose tax rate is 0% so that it can be used in tracking the total sales or purchases with this tax item using the tax tracking feature provided by OneStep.

### 3.9 Setting Up Preferences

There are a number of system preferences that you need to set up before starting out with OneStep.

To set up these parameters, select Administration ➔ Preferences from the menu bar.

The Preferences function also lets you set up values that are frequently used so that these values would appear as the default values wherever they are needed.
Below explains the various settings on the Preferences Form:

Under the 'System / General' tab:

➢ Check the 'Use Audit Trail' field if you want to keep track of the changes made to transactions. It is always a good idea to turn on the audit trail feature as it allows you to track changes made to your business transactions.

➢ Check the 'Allow Inventory To Go Negative' field if you want to allow the quantity values of your items to go negative. Beware that if you sell an item with a negative quantity, its cost of goods sold will be computed based on the cost price value you set for that item instead of the using the selected cost method.

➢ Select the sales price table to use.

Under the 'System / Posting Accounts' tab:

➢ Select the retained earnings account to be used.
Under the 'Frequently Used Values / General' tab:

➢ Select the payment method.
➢ Select the account to which early payment discount for sales will be posted.
➢ Select the default account to which early payment discount for purchase will be posted.

Under the 'Frequently Used Values / Item' tab:

The default values used when creating a new item.

➢ Select the account to which sales will be posted.
➢ Select the account to which sales return will be posted.
➢ Select the account to which purchases for non-inventory items and services will be posted.
➢ Select the control account for inventory item.
➢ Select the cost of goods sold account for inventory item.
➢ Select the cost method for inventory item.

Under the 'Frequently Used Values / Customer' tab:

The default values used when adding a new customer.

➢ Select the control account.
➢ Select the credit terms..
➢ Set the credit limit.
➢ Select the tax item be applied.
➢ Check 'Calc. Tax After Disc' if you want the tax amount to be calculated based on total amount less early payment discount.
Under the 'Frequently Used Values / Vendors' tab:

The default values used when adding a new vendor.

➢ Select the control account.
➢ Select the credit terms.
➢ Set the credit limit.
➢ Select the tax item be applied.
➢ Check ‘Calc. Tax After Disc’ if you want the tax amount to be calculated based on total amount less early payment discount.

3.10 Setting Up Items

Items are services or products that you buy and sell. In OneStep, besides the item that you buy and sell, you can also add items that represent discounts, subtotal, tax items and comments.

To add an item, select Item ➢ Items from either the menu or the tool bar.

Click on the New button of the Item List form to create a new item.

Below describes how you can setup the various types of items in OneStep.

Inventory Product

You add an inventory product item when you would like its quantity and cost to be tracked when it is purchased and sold.

To add an inventory product item, enter the followings:

➢ Name of the item.
➢ Select ‘Inventory Product’ under the ‘Type’ field.
Under the 'Item' tab:

➢ Description of this item.
➢ Sales Price of this item.
➢ Cost Price of this item if its quantity is negative.
➢ Check the 'Taxable' field if this you need to applied sales tax to this item.
➢ Preferred Vendor of this item.
➢ Category to which the item belongs. Used in management reporting only.
➢ Subcategory to which the item belongs. Used in management reporting only.

Under the ‘Inventory’ tab:

➢ Select the cost method of this item. Cost methods available are Average, First-In-First-Out and Last-In-First-Out.
➢ Minimum quantity required.
➢ Reorder quantity.

Under the ‘Account’ tab:

➢ Select the posting account for sales.
➢ Select the posting account for sales return.
➢ Select the posting account for cost of goods sold.
➢ Select the control account.
Services

You add Service items, if you are offering services to your customer in your business.

To add a service item, enter the followings:

➢ Name of the item.
➢ Select ‘Service’ under the ‘Type’ field.

Under the 'Item' tab:

➢ Description of the item.
➢ Sales Price of the item.
➢ Cost Price of the item if you purchase this service.
➢ Check the 'Taxable' field if you need to applied sales tax to this item.
➢ Preferred Vendor of this item.
➢ Category to which the item belongs. Used in management reporting only.
➢ Subcategory to which the item belongs. Used in management reporting only.

Under the ‘Account’ tab:

➢ Select the posting account for sales.
➢ Select the posting account for sales return.
➢ Select the posting account for purchase. In our example, we leave the this field blank because we do not need to purchase any repair service from others.
Sub-Total

As its name implies, a Sub-Total item gives you a subtotal of all amounts come before it in an invoice.

To add a Sub-Total item, enter the followings:

➢ Name of the item.
➢ Select ‘Service’ under the ‘Type’ field.

Under the 'Item' tab:

➢ Description of the item.

Percentage

Percentage discounts and percentage mark-ups can be created using the Percentage Item.

To add a Percentage Discount item, enter the followings:

➢ Name of the item.
➢ Select ‘Service’ under the ‘Type’ field.

Under the 'Item' tab:

➢ Description of the item.
➢ Percentage value for the discount.
➢ Check the 'Taxable' field if this you need to applied sales tax to the discount.

Under the ‘Account’ tab:

➢ Select the posting account for sales.
➢ Select the posting account for sales return.
➢ Select the posting account for purchase.
3.11 Setting Up Customers

To add a customer record, select Sales→Customers from either the menu or the tool bar.

Click on the New button of the Customer List Form to add a new customer.

Enter the followings:

- Name of the customer.
- Printed name of the customer

Under the 'Company' tab:

- Name of the contact person.
- Phone numbers.
- Fax number.
- Bill to and ship to addresses.

Under the 'Account' tab:

- Select the control account.
- Set the credit limit.
- Select the credit terms.
- Select the tax to be applied.
- Check 'Calc. Tax After Disc' if you want the tax amount to be calculated based on total amount after early payment discount.
- Select the sales representative for this customer account if any.
- Select the price group the customer belongs to. Leave it blank if the customer does not belong to any price group.

3.12 Setting Up Vendors
To add a vendor record, select Purchase→Vendors from either the menu or the tool bar.

Click on the New button of the Vendor List Form to add a new vendor.

Enter the followings:

- Name of the vendor.
- Printed name of the vendor

Under the 'Company' tab:

- Name of the contact person.
- Phone numbers.
- Fax number.
- Address.

Under the 'Account' tab:

- Select the control account.
- Set the credit limit.
- Select the credit terms.
- Select the tax to be applied.
- Check 'Calc. Tax After Disc' if you want the tax amount to be calculated based on total amount after early payment discount.
- Tax registration number or Tax ID number.

3.13 Setting Up Opening Balances

Opening balances are the amounts in your accounts just before your start date.
In OneStep, you enter the opening balances by posting general journal entries and inventory adjustments just like you would for other transactions.

To add a general journal entry, select GL → General Journal from either the menu or the tool bar.

Click on the New button of the General Journal List Form to add a new general journal entry.

Enter the followings:

- Leave the GJ No blank as it will be automatically generated when you save the general journal entry.
- The date that is one day before the start date. In our example, our start date is 1st April 2003, so we enter 31st March 2003 as the date value.
- Description for the posting. In our example, we set it to 'Opening Balances'.

For each account, enter the followings:

- Select the account type.
- Select the account.
- Debit or credit balance of the account.

Note: As the posting above does not include the balance for your inventory, the balance of the retained earning account entered equals to the actual account balance less the balance of your inventory.

To add an inventory adjustment, select Item → Inventory Adjustments from either the menu or the tool bar.
Click on the New button of the Inventory Adjust List Form to add a new inventory adjustment.

Enter the followings:

- Leave the Adjustment No blank as it will be automatically generated when you save the general journal entry.
- The date that is one day before the start date. In our example, our start date is 1st April 2003, so we enter 31st March 2003 as the date value.
- Description for the posting. In our example, we set it to 'Opening Balances'.
- Select the Retained Earnings account as your adjustment account.

For each item, enter the followings:

- Inventory item.
- Quantity balance of the item.
- Cost of the item.

Note: We choose to use the Retained Earnings account as our adjustment account because in our previous General Journal posting, we offset the balance this account for our inventory balance.

3.14 Setting Up Outstanding Sales Invoices And Credit Memos For Opening

If there are outstanding sales invoices as of your start date and you want OneStep to help you keep track of them, you enter them through the opening invoices and credit memos dialog.

To bring up the opening invoices and credit memos dialog, select Sales→Customers from either the menu or the tool bar to open the Customer List Form.
Double click on the customer for which you would like to set up outstanding invoices to bring up the Customer Record Form.

Click on the Opening... button to bring up the opening invoices and credit memos dialog.

For each outstanding invoice, enter the followings:

- Invoice number.
- Invoice date.
- Due date.
- Discount percentage for early payment.
- Discount date for early payment.
- Amount for this invoice.

Note: You can also enter outstanding credit memos through the opening invoice and credit memos dialog by selecting the credit memos tab.

3.15 Setting Up Outstanding Purchase Invoices And Debit Memos For Opening
If there are outstanding purchase invoices as of your start date and you want OneStep to help you keep track of them, you enter them through the opening invoices and debit memos dialog.

To bring up the opening invoices and debit memos dialog, select Purchase → Vendors from either the menu or the tool bar to open the Vendor List Form.

Double click on the vendor for which you would like to set up outstanding invoices to bring up the Vendor Record Form.

Click on the Opening... button to bring up the opening invoices and debit memos dialog.

For each outstanding invoice, enter the followings:

- Invoice number.
- Invoice date.
- Due date.
- Discount percentage for early payment.
- Discount date for early payment.
- Amount for this invoice.

Note: You can also enter outstanding debit memos through the opening invoice and debit memos dialog by selecting the debit memos tab.
3.16 Setting Up Document References

For some of the business documents (e.g. Your sales invoice, cash sales, etc.), OneStep will auto-generate their document references if their reference fields are left blank. You can set up how these reference numbers are to be generated through the Document References function.

The generated reference numbers have the following format

Prefix + Running Number + Suffix

To access the Document References function, select Admin→Document References from the menu bar.

Change the following values accordingly:

➢ Prefix string.
➢ The last-used running number.
➢ The minimum number of digits for the running number. '0' will be padded in front of the running number where necessary.
➢ Suffix string.

3.17 Entering Historical Transactions

Now that you have completed the necessary steps to set up OneStep for your business, you can start entering historical transactions since the start date till the present day. Please see the chapter on 'Transaction Examples' for examples on how to enter some of the common transactions.

3.18 Customizing The Printouts Of Your Business Documents

You may also want to customize the printout of your business documents (e.g. adding a logo to your sales invoice's printout); you can do so via the built-in graphical report builder.

The report builder can be accessed via the Select Report Form of individual business document's record form.

To customize your sales invoice, select Sales→Invoices from the either menu or tool bar to open the sales invoice list form.
Double click on any of the invoices on the list form to bring up the sales invoice record form. Click on the Others... button of the sales invoice record form and select the Select Report Form command to bring up the Select Report Form dialog.

While at the Select Report Form, you can either click on the New button to create a new printout format for sales invoice or select the Edit button to edit an existing one. Of course, for most of the time, it will be easier to change an existing one that is close to what you want than to create a new one from scratch.
To change an existing printout format, double click on the printout format you want to bring up Report Builder.

**Click on the Design tab to design your printout.**

**Click on the Preview tab to see how your printout will look.**

The Report Builder is where you customize your printout format. It contains four workspaces: Data, Calc, Design and Preview. You will be using the Design and Preview workspaces most of the time as the Design workspace is where you design or customize your printout and the Preview workspace lets you preview your design on screen.

While you are at the Design workspace, you can pick up components from the component palette and drop them on the various bands to build the content of your printout.

There are two sets of components, the standard components and the data-aware components. Standard components are for you to add static text and images whereas data-aware components allow you to add text and images that are linked to data fields.

**Setting Up OneStep For Your Business** 41
Dropping a component into the different bands of the Design workspace yields different results. Components placed in the header band will appear at the top of your page, components placed in the detail band will appear as the body of your page, components placed in the footer band will appear at the bottom of your page, components placed in the summary band will appear once at the end of your printing and components placed in the page style band will appear as the background of your page.

To add a logo, click on the image component followed by clicking on the header band to drop the image component into the header band.

Right click on the Image component you have just dropped into the header band and then followed by selecting the Picture ... command to select a graphic image for the Image component.
Click on Picture...

Select a Graphic File and Click on the Open Button.
After loading the image you want, you can switch to the Preview workspace by clicking on the Preview tab to see how your printout will look with the new logo.

Switch back to the Design workspace to fine tune the position of the logo by selecting the image component and dragging it to the desired position with your mouse.

You can made further changes to your design, by either adding new components, re-positioning or deleting existing components, etc.

Once you are satisfied with the design, select File  Save from the menu of the Report Builder to save the changes you have made.
4 Sales Processing

Sales processing is a series of activities starting from providing quotations to your customers, to receiving customer orders, to delivering the goods, and invoicing your customers. OneStep provides the necessary functions to support all these activities and manages all the records involved.

The diagram below depicts the documents found in sales processing.

The arrows in the diagram indicate that you can convert from one type of document to the other. For example, if your customer has accepted a quotation you prepared previously and has sent you an order based on that quotation, you can then use OneStep to convert the quotation to a sales order for you. This will save you the trouble of re-entering all the relevant data.

Take note that OneStep does not impose that you have to start your sales process from quotation; you can start your sales process from any point except for delivery order. A delivery order has to be based on a particular sales order.

The sections that follow will each of the documents above.

Note: Quotation, Sales Order and Delivery Order are only available in the Professional Editions.

4.1 Quotation (Available in Professional Edition Only)

When a customer is considering making a purchase, he will frequently begin by making enquiries about how much the goods or services will cost, that is, he will ask for a quotation for the goods or services he requires.

To work with quotations in OneStep, select Sales→Quotations from either the menu or the tool bar.

4.1.1 Quotation List Form

Below describes the components pertaining to the Quotation list form. Please refer to “Working with OneStep, The List Form” for components not described here.
Data Fields

**Date**: The date of the quotation.

**Quotation No**: The quotation’s reference number.

**Customer**: The customer’s name.

**Total**: The total amount of the quotation.

**Closed**: Indicates whether the quotation is closed.

4.1.2 Quotation Record Form

Below describes the components pertaining to the Quotation record form. Please refer to “Working with OneStep, Record Form” for components not described here.

Data Fields

**Customer Account / Name**: The customer’s account and name.

**Attn**: The person to attention to.

46 Sales Processing
Date: Date of the quotation.

Quotation No: The reference number of the quotation. If this field is left blank, OneStep will automatically generate the next quotation number for you.

Bill To: The customer’s billing address. OneStep will automatically fill in this field based on the customer’s record when you complete the Customer Account field.

Ship To: The customer’s ship-to address. OneStep will automatically fill in this field based on the customer’s record when you complete the Customer Account field.

Good Through: The validity date of the quotation.

Your Ref: Customer’s internal reference.

Sales Rep: The sales person preparing the quotation.

Terms: The payment terms. OneStep will automatically fill in this field based on the customer’s record when you complete the Customer field.

Ship Date: If your customer requires that the goods to be shipped by a particular date, you can enter the date here.

Via: The method of transportation. For example, UPS, Fed Ex, etc.

FOB: Stands for “Free On Board”; refers to the point where freight is paid.

Item: Enter the item you want to include in the quotation here. If you leave this field blank then the line will become a comment line and you can enter your comment in the Description field.

Description: Description of the item. OneStep will automatically fill in this field based on the item’s record when you complete the Item field.

Qty: The number of units you are quoting for the item.

Unit Price: The price per unit you are quoting for the item. OneStep will automatically fill this field based on the Item and Qty fields and the price table. You can override this value if needed.

Amount: The total line amount that is calculated by multiplying Qty and Unit Price. OneStep will automatically calculate this value whenever the Qty or Unit Price changes.

Tax (on the item line): Check this field if the item line is to be included for computing the tax amount. OneStep will automatically fill in this field based on the item’s record when you complete the Item field.

Tax: The tax item used, the tax rate and the tax amount. OneStep will automatically fill in the tax item and tax rate based on the customer’s record when you complete the Customer field.

Calc. Tax After Discount (The Check Box Next To Tax Field): Check this if you want OneStep to calculate the tax amount based on total amount less early payment discount.

Total: The total amount of the quotation. OneStep will automatically calculate this value for you.

Closed: You close a quotation when you are no longer interested in it. OneStep will automatically close a quotation when you convert it to a sales order. You can also manually close a quotation by checking this field.

Taxable Total: The taxable total on which the tax is based. Apply only to tax item.
Command Buttons

Others → Create Order: Click this button to convert the quotation into a sales order. OneStep will also check for the credit limit of the customer for you during the conversion and if the credit limit is exceeded, you can choose to continue with or abort the conversion.

Others → Create Invoice: Click this button to convert the quotation into a sales invoice. OneStep will also check for the credit limit of the customer for you during the conversion and if the credit limit is exceeded, you can choose to continue with or abort the conversion.

Others → Print Preview: Click this button to save the quotation and preview the printout of the quotation.

Others → Select Report Form: Click this button to bring up the Select Report Form dialog.

Others → Custom Fields: Click this button to bring up the Custom Fields dialog to edit on the custom fields.

Print: Click this button to save and print the quotation.

Others:

Edit Taxable Total: If you add a tax item to the list of item lines then you can edit the taxable total of the tax item by right clicking on the item line and selecting the edit taxable total command.

4.2 Sales Order (Available In Professional Edition Only)

When a customer wants to buy from you the goods or services he requires, he will usually send you an order. To aid the decision about what to buy and whom to buy from, the customer may request for a quotation first, as described earlier.

To work with sales orders in OneStep, select Sales → Orders from either the menu or the tool bar.

4.2.1 Sales Order List Form

Below describes the components pertaining to the Sales Order list form. Please refer to “Working with OneStep, List Form” for components not described here.

Data Fields

Date: The Date of the sales order.
**Order No:** The order’s reference number.

**Customer:** The customer’s name.

**Total:** The total amount of the sales order.

**Shipped:** Indicates whether the items in the order have been shipped.

**Closed:** Indicates whether the order has been closed.

### 4.2.2 Sales Order Record Form

Below describes the components pertaining to the Sales Order record form. Please refer to “Working with OneStep, Record Form” for components not described here.

![Sales Order Record Form](image)

**Data Fields**

**Customer Account / Name:** The customer’s account and name.

**Attn:** The person to attention to.

**Date:** Date of the order.

**Order No:** Our reference number for the order. If this field is left blank, OneStep will automatically generate the next order number for you.

**Bill To:** The customer’s billing address. OneStep will automatically fill in this field based on the customer’s record when you complete the Customer Account field.

**Ship To:** The customer’s ship-to address. OneStep will automatically fill in this field based on the customer’s record when you complete the Customer Account field.

**Your Ref:** Customer’s reference number, usually this will be the customer order number.

**Our Ref:** Our internal reference. If this is converted from a quotation, OneStep will automatically fill in this field with the quotation number.
Sales Rep: The sales person preparing the sales order.

Terms: The payment terms. OneStep will automatically fill in this field based on the customer’s record when you complete the Customer Account field.

Ship Date: If your customer requires that the goods to be shipped by a particular date, you can enter the date here.

Via: The method of transportation. For example, UPS, Fed Ex, etc.

FOB: Stands for “Free On Board”; refers to the point where freight is paid.

Item: Enter the item you want to include in the order here. If you leave this field blank then the line will become a comment line and you can enter your comment in the description field.

Description: Description of the item. OneStep will automatically fill in this field based on the item’s record when you complete the Item field.

Qty: The number of units you are selling for the item.

Shipped (Item Line): The number of items that have been shipped. This value will be automatically updated when you include the item for this sales order in a delivery order.

Unit Price: The price per unit you are selling for the item. OneStep will automatically fill this field based on the Item and Qty fields and the price table. You can override this value if needed.

Amount: The total line amount that is calculated by multiplying Qty and Unit Price. OneStep will automatically calculate this value whenever the Qty or Unit Price changes.

Tax (on the item line): Check this field if the item line is to be included for computing the tax amount. OneStep will automatically fill in this field based on the item’s record when you complete the item field.

Tax: The tax item used, the tax rate and the tax amount. OneStep will automatically fill in the tax item based on the customer’s record when you complete the Customer Account field.

Calc. Tax After Discount (The Check Box Next To Tax Field): Check this if you want OneStep to calculate the tax amount based on total amount less early payment discount.

Total: The total amount of the whole quotation. OneStep will automatically calculate this value for you.

Deposit: The amount that the customer has deposited for this order. You can use the deposit function to make a deposit.

Balance: An amount equals to total amount less deposit amount.

Shipped: When all the items in the order have been shipped, this value is set to true automatically. You are not allowed to change the value manually.

Closed: You close a sales order when you are no longer interested in it (usually because you have already created a corresponding sales invoice for the order or the order is canceled). OneStep will automatically close a sales order when you convert it to a sales invoice. You can also close a sales order manually.

Command Buttons

Others→Create Delivery Order: Click this button to create a delivery order based on the sales order.

Others→Create Invoice: Click this button to convert the sales order into a sales invoice. OneStep will also check for the credit limit of the customer for you during the conversion.
Others→Print Preview: Click this button to save the sales order and preview the printout of the sales order.

Others→Select Report Form: Click this button to bring up the Select Report Form dialog.

Others→Custom Fields: Click this button to bring up the Custom Fields dialog to edit on the custom fields.

Print: Click this button to save and print the sales order.

Deposit: Click this button to make a deposit for the customer. The deposit will be recorded as a cash receipt from this customer.

Ok: Click this button to save the sales order. OneStep will check the credit limit of the customer and prompt you when the credit limit is exceeded.

Others:

Edit Taxable Total: If you add a tax item to the list of item lines then you can edit the taxable total of the tax item by right clicking on the item line and selecting the edit taxable total command.

4.3 Delivery Order (Available In Professional Edition Only)

A delivery order lists the goods that you send to your customer. It is a very useful document because it allows the customer to check what they are receiving and sign on it to acknowledge the delivery has taken place.

To work with delivery orders in OneStep, select Sales→Delivery Orders from either the menu or the tool bar.

4.3.1 Delivery Order List Form

Below describes the components pertaining to the Delivery Order list form. Please refer to “Working with OneStep, List Form” for components not described here.

Data Fields

Date: The date of the delivery order.

DO No: The delivery order’s reference number.

Customer: The customer’s name.

Status: Indicates whether the delivery is in picking stage or it has been shipped.
Closed: Indicates whether the delivery order has been closed.

4.3.2 Delivery Order Record Form

Below describes the components pertaining to the Delivery Order record form. Please refer to “Working with OneStep, Record Form” for components not described here.

Data Fields

Customer Account: The customer account. If the delivery order is converted from a sales order, OneStep automatically fills this field.

Attn: The person to attention to.

Date: Date of the order.

DO No: The reference number for the delivery order. If this field is left blank, OneStep will automatically generate the next order number for you.

Sales Order / Customer Name: The sales order of which the items are shipped in this delivery order and the customer name on the sales order. If the delivery order is converted from a sales order, OneStep automatically fills this field.

Status: Indicates whether the delivery is in picking stage or it has been shipped.

Bill To: The customer’s billing address. OneStep will automatically fill in this field based on the customer’s record when you complete the Customer Account field.

Ship To: The customer’s ship-to address. OneStep will automatically fill in this field based on the customer’s record when you complete the Customer Account field.

Your Ref: Customer’s internal reference.

Ship Date: If the shipped date is different from the delivery order date then you can enter the date here.

Via: The method of transportation. For example, UPS, Fed Ex, etc.

52 Sales Processing
Item: The item you are shipping. You cannot edit this field directly. You have to use the ‘Add’ function to add an item line to the delivery order.

Description: Description of the item. You cannot edit this field directly. You have to use the ‘Add’ function to add an item line to the delivery order.

Remaining: The remaining quantity of the item of the associated sales order that has yet to be shipped.

Qty: The number of units you are shipping for the item.

Remark (on item line): For you to add any remark to the item delivered.

Closed: You can close a delivery order when you are no longer interested in it (usually because you have already create a corresponding sales invoice for the delivery order or the delivery order is canceled). OneStep will automatically close a delivery order when you convert it to a sales invoice. You can also manually close a delivery order.

Remark: Enter any remark for the delivery order here.

Command Buttons

Fill All: Click this button to fill all the items in the delivery order. That is, to set all the Qty values equal to the respective Remaining values so that all the remaining items that are not yet shipped will be shipped in this delivery order.

Add: Click this button to call up a dialog for selecting items that have yet to be shipped from the selected sales order.

Others→Create Invoice: Click this button to create a sales invoice based on the delivery order. OneStep will also check for the credit limit of the customer for you during the conversion and the when credit limit is exceeded you can choose to continue with or abort the conversion.

Others→Print Preview: Click this button to save the delivery order and preview the printout of the delivery order.

Others→Select Report Form: Click this button to bring up the Select Report Form dialog.

Others→Due Date: Click this button to bring up the Due Date dialog to view or change the due date. Please note that the due date will be overridden whenever the invoice date or terms changes.

Others→Custom Fields: Click this button to bring up the Custom Fields dialog to edit on the custom fields.

Print: Click this button to print the delivery order.

4.4 Sales Invoice

A sales invoice is sent to the customer to bill him/her for the goods and services your have delivered.

To work with sales invoices in OneStep, select Sales→Invoices from either the menu or the tool bar.

4.4.1 Sales Invoice List Form

Below describes the components pertaining to the Sales Invoice list form. Please refer to “Working with OneStep, List Form” for components not described here.
Data Fields

**Date**: The date of the invoice.

**Invoice No**: The invoice’s reference number.

**Customer**: The customer’s name.

**Due Date**: The due date of the invoice.

**Disc. Date**: The date by which discount will be given if early payment is made.

**Total**: The total amount of the invoice.

**Amt. Due**: The amount still outstanding.

**Closed**: Indicate whether the invoice has been closed.

### 4.4.2 Sales Invoice Record Form

Below describes the components pertaining to the Sales Invoice record form. Please refer to “Working with OneStep, Record Form” for components not described here.
Data Fields

**Customer Account / Name:** The customer’s account and name.

**Attn:** The person to attention to.

**Date:** Date of the invoice.

**Invoice No:** The reference number for the invoice. If this field is left blank, OneStep will automatically generate the next invoice number for you.

**Bill To:** The customer’s billing address. OneStep will automatically fill in this field based on the customer’s record when you complete the Customer Account field.

**Ship To:** The customer’s ship-to address. OneStep will automatically fill in this field based on the customer’s record when you complete the Customer Account field.

**Your Ref:** Customer’s internal reference. Usually this will be the customer’s PO number.

**Our Ref:** Our internal reference. If this is converted from a sales order, OneStep will automatically fill in this field with the sales order number. If this is converted from a delivery order, OneStep will automatically fill in this field with the delivery order number.

**Sales Rep:** The sales person preparing the sales invoice.

**Terms:** The credit terms. OneStep will automatically fill in this field based on the customer’s record when you complete the Customer Account field.

**Ship Date:** If your customer requires that the goods be shipped by a particular date, you can enter the date here.

**Via:** The method of transportation. For example, UPS, Fed Ex, etc.

**FOB:** Stands for “Free On Board”; refers to the point where freight is paid.

**Item:** Enter the item you want to include in the invoice here. If you leave this field blank then the line will become a comment line and you can enter your comment in the description field.

**Description:** Description of the item. OneStep will automatically fill in this field based on the item’s record when you complete the Item field.

**Qty:** The number of units you are selling for the item.

**Unit Price:** The price per unit you are selling for the item. OneStep will automatically fill this field based on the Item and Qty fields and the price table. You can override this value if needed.

**Amount:** The total line amount that is calculated by multiplying Qty and Unit Price. OneStep will automatically calculate this value whenever the Qty or Unit Price changes.

**Tax (on the item line):** Check this field if the item line is to be included for computing the tax amount. OneStep will automatically fill in this field based on the item’s record when you complete the Item field.

**Tax:** The tax item used, the tax rate and the tax amount. OneStep will automatically fill in the tax item based on the customer’s record when you complete the Customer Account field.

**Calc. Tax After Discount (The Check Box Next To Tax Field):** Check this if you want OneStep to calculate the tax amount based on the total amount less early payment discount.

**Total:** The total amount of the whole invoice. OneStep will automatically calculate this value for you.
**Deposit:** The amount that the customer has deposited for this invoice.

**Balance:** An amount equals to the total amount less the deposit amount.

**Closed:** You close a sales invoice when you are no longer interested in it (usually because you have received payment for the invoice). OneStep will automatically close a sales invoice when it is fully paid.

**Command Buttons**

**Others ➔ Void Invoice:** Click this button to set the quantity values of all the items to zero.

**Others ➔ Payment History:** Click this button to view the payment history for this invoice.

**Others ➔ Print Preview:** Click this button to save the invoice and preview the printout.

**Others ➔ Select Report Form:** Click this button to bring up the Select Report Form dialog.

**Others ➔ Custom Fields:** Click this button to bring up the Custom Fields dialog to edit on the custom fields.

**Print:** Click this button to save and print the sales invoice.

**Ok:** Click this button to save the sales invoice. OneStep will check the credit limit of the customer and prompt you when the credit limit is exceeded.

**Others:**

**Edit Taxable Total:** If you add a tax item to the list of item lines then you can edit the taxable total of the tax item by right clicking on the item line and selecting the edit taxable total command.

**Edit Cost Of Goods:** If you add a inventory item to the list of item lines then you can edit the cost of good of item by right clicking on the item line and selecting the edit cost of good command. Usually, the system will compute the cost of goods automatically. This function is used only when you want to dictate the cost of good for the item in this invoice.

### 4.5 Credit Memo

Sometimes, your customers sent back the goods you have sent him because of damages or other reasons and to compensate your customers you either reduce the credit amount you have extended to the customer or refund him with cash. To record the compensation you create a credit memo.

To work with a credit memo in OneStep, select Sales ➔ Credit Memos from either the menu or the tool bar.

#### 4.5.1 Credit Memo List Form

Below describes the components pertaining to the Credit Memo list form. Please refer to “Working with OneStep, List Form” for components not described here.
Data Fields

**Date:** The date of the memo.

**Credit No:** The credit memo’s reference number.

**Customer:** The customer’s name.

**Type:** The type of credit memo, credit or cash refund.

**Total:** The total amount of the memo.

**Closed:** Indicates whether the memo has been closed.

### 4.5.2 Credit Memo Record Form

Below describes the components pertaining to the Credit Memo record form. Please refer to “Working with OneStep, Record Form” for components not described here.

Data Fields

**Customer Account / Name:** The customer’s account and name.

**Attn:** The person to attention to.
Date: Date of the credit memo.

Memo No: The reference number for the credit memo. If this field is left blank, OneStep will automatically generate the next memo number for you.

Bill To: The customer’s address. OneStep will automatically fill in this field based on the customer’s record when you complete the Customer Account field.

Type: Indicates whether the credit memo is to credit the customer account or is it a cash refund to the customer.

Pay From: If the credit memo is a cash refund to the customer, set this field to the account from which the cash refund is paid out.

Sales Rep: The sales person preparing the credit memo.

Payment Method: The method of payment. For example, cash or check, etc.

Payment Ref: The payment’s reference number. For example, the check number, the visa card number, etc.

Item: Enter the item you want to include in the memo here. If you leave this field blank then the line will become a comment line and you can enter your comment in the Description field.

Description: Description of the item. OneStep will automatically fill in this field based on the item’s record when you complete the Item field.

Qty: The number of units you are selling for the item.

Unit Price: The price per unit you set for the item. OneStep will automatically fill this field based on the Item and Qty fields and the price table. You can override this value if needed.

Amount: The total line amount that is calculated by multiplying Qty and Unit Price. OneStep will automatically calculate this value whenever the Qty or Unit Price changes.

Tax (on the item line): Check this field, if the item line is to be included to compute the tax amount. OneStep will automatically fill in this field based on the item’s record when you complete the Item field.

Tax: The tax item used, the tax rate and the tax amount. OneStep will automatically fill in the tax item based on the customer’s record when you complete the Customer Account field.

Total: The total amount of the credit memo. OneStep will automatically calculate this value for you.

Closed: You close a credit memo when you are no longer interested in it (usually because the credit of this credit memo has been applied or the credit memo is canceled). OneStep will automatically close a credit memo when its credit is fully deducted.

Adjust Inventory: This field indicates whether the items listed in the credit memo are to be returned to the inventory. If the customer is just asking for a discount for a defected item but is not returning the item to you, then uncheck this field.

Command Buttons

Others ➔ Applied History: Click this button to view the applied history for this memo.

Others ➔ Print Preview: Click this button to save the memo and preview the printout.

Others ➔ Select Report Form: Click this button to bring up the Select Report Form dialog.
Others→Custom Fields: Click this button to bring up the Custom Fields dialog to edit on the custom fields.

Print: Click this button to print the memo.

Others:

Edit Taxable Total: If you add a tax item to the list of item lines then you can edit the taxable total of the tax item by right clicking on the item line and selecting the edit taxable total command.

Edit Cost Of Goods: If you add a inventory item to the list of item lines then you can edit the cost of good of item by right clicking on the item line and selecting the edit cost of good command. Usually, the system will compute the cost of goods automatically. This function is used only when you want to dictate the cost of good for the item in this credit memo.

4.6 Cash Sales

To record sales when payment is received at the point of sales, you can use the cash sales function in OneStep. To work with cash sales, select Sales→Cash Sales from either the menu or the tool bar.

Cash Sales List Form

Below describes the components pertaining to the Cash Sales list form. Please refer to “Working with OneStep, List Form” for components not described here.

Data Fields

Date: The date of the cash sales.

Sales No: The cash sales’ reference number.

Customer: The customer’s name.

Total: The total amount of the cash sales.

4.6.1 Cash Sales Record Form

Below describes the components pertaining to the Cash Sales record form. Please refer to “Working with OneStep, Record Form” for components not described here.
Data Fields

**Customer Account / Name:** customer’s account and name. These fields are optional since for cash sales you may not need to record the customer you are selling to.

**Date:** Date of the cash sales.

**Sales No:** The reference number of the sales. If this field is left blank, OneStep will automatically generate the next sales number for you.

**Bill To:** The customer’s billing address. OneStep will automatically fill in this field based on the customer’s record if you have selected an existing customer at the Customer Account field.

**Ship To:** Customer’s ship-to address. OneStep will automatically fill in this field based on the customer’s record if you have selected an existing customer at the Customer field.

**Payment Method:** The method of payment. For example, cash or check, etc.

**Payment Ref:** The payment’s reference number. For example, the check number, the visa card number, etc.

**Sales Rep:** The sales person conducting the cash sales.

**Via:** The method of transportation. For example, UPS, Fed Ex, etc.

**FOB:** Stands for “Free On Board”; refers to the point where freight is paid.

**Item:** Enter the item you want to include in the sales here. If you leave this field blank then the line will become a comment line and you can enter your comment in the Description field.

**Description:** Description of the item. OneStep will automatically fill in this field based on the item’s record when you complete the Item field.

**Qty:** The number of units you are selling for the item.

**Unit Price:** The price per unit you set for the item. OneStep will automatically fill this field based on the Item and Qty fields and the price table. You can override this value if needed.

**Amount:** The total line amount that is calculated by multiplying Qty and Unit Price. OneStep will automatically calculate this value whenever the Qty or Unit Price changes.
**Tax (on the item line):** Check this field if the item line is to be included for computing the tax amount. OneStep will automatically fill in this field based on the item’s record when you complete the Item field.

**Tax:** The tax item used, the tax rate and the tax amount. OneStep will automatically fill in the tax item based on the customer’s record when you complete the Customer Account field.

**Total:** The total amount of the cash sales. OneStep will automatically calculate this value for you.

**Deposit To:** The account to deposit the money received on the cash sales.

**Tender:** The amount the customer tenders.

**Change:** The change you have to return to the customer.

**Command Buttons**

**Others→Void Sales:** Click this button to set the quantity values of all the items to zero.

**Others→Print Preview:** Click this button to save the sales and preview the printout.

**Others→Select Report Form:** Click this button to bring up the Select Report Form dialog.

**Others→Custom Fields:** Click this button to bring up the Custom Fields dialog to edit on the custom fields.

**Print:** Click this button to print the cash sales.

**Others:**

**Edit Taxable Total:** If you add a tax item to the list of item lines then you can edit the taxable total of the tax item by right clicking on the item line and selecting the edit taxable total command.

**Edit Cost Of Goods:** If you add a inventory item to the list of item lines then you can edit the cost of goods of the item by right clicking on the item line and selecting the edit cost of goods command. Usually, the system will compute the cost of goods automatically. This function is used only when you want to dictate the cost of goods for the item in this cash sales.

### 4.7 Customer

You can create a customer record using the customer function in OneStep. To work with customer records, select Sales→Customers from either the menu or the tool bar.

#### 4.7.1 Customer List Form

Below describes the components pertaining to the Customer list form. Please refer to “Working with OneStep, List Form” for components not described here.
Data Fields

Name: The customer’s name.

Credit Limit: The customer’s credit limit.

Balance: The amount the customer owes you.

Command Buttons

Others→Print Account Journal: Click this button to bring up Print Account Journal window for printing of customer account journal.

Others→Statement→Preview: Click this button to preview the statement of account of the selected customer.

Others→Statement→Print: Click this button to print the statement of account of the selected customer.

Others→Statement→Print All: Click this button to print the statement of account of all the customers in the list.

Others→Statement→Print All (> 0): Click this button to print the statement of account of all the customers in the list whose balance is greater than 0.

Others→Statement→Select Report Form: Click this button to bring up the Select Report Form dialog. You can choose to print a Customer Statement based on ‘Open Item’ or a Customer Statement based on the ‘Balance Forward’.

4.7.2 Customer Record Form

Below describes the components pertaining to the Customer record form. Please refer to “Working with OneStep, Record Form” for components not described here.
Data Fields

Name: The name of the customer.

Printed Name: The name to be used when the customer’s name is printed. Sometimes you can use an abbreviated name for the name field and enter the full customer name in the printed field.

Active: Indicates whether the customer is still active. Inactive customers will not appear in the customer selections for sales.

Under the ‘Company’ tab:

Contact: The contact person.

Phone: The customer’s phone number.

Fax: The customer’s fax number.

Sold To Address: The customer’s address for billing.

Ship To Address: If the customer has a separate shipping address, enter the address here.

Under the ‘Account’ tab:

Control Account: The receivable account in general ledger under which the customer should be grouped.

Credit Limit: The credit amount your company allows for this customer. OneStep will warn you when the customer is about to exceed the credit limit.

Terms: The default credit terms for this customer.

Tax: The tax type associated with this customer.

Calc. Tax After Discount: Check this if you want OneStep to calculate the tax amount based on the total amount less early payment discount for this customer.

Sales Rep: The default sales person assigned to this customer.

Price Group: The price group that this customer belongs. OneStep will use the price group to cross-reference a price table to obtain the pricing when you sell goods to the customer.
**Balance**: The account balance of the customer. That is, the amount the customer owes you.

Under the 'Custom Fields' tab:

**Field 1 to Field 5**: These are the fields that you can use to record additional data required for the customer

Under the 'Memo 1' to 'Memo 3' tab:

**Memo Fields**: Just like custom fields, the memo fields are for you to record additional data for the customer. However, unlike custom fields there is no restriction to the number of characters you can enter to these fields.

**Command Buttons**

**Openings …**: Click this button to call up the opening invoices and credit memo dialog for entering outstanding opening invoices and credit memos that have been posted. Used only when you first set up OneStep.

### 4.7.3 Opening Invoices and Credit Memos Dialog

This dialog allows you to enter outstanding sales invoices and credit memos that you have already posted to you accounts but have yet to close when you switch over to OneStep (Please note that OneStep will not post these transactions). OneStep will use this information to compute the aging report as well as allow you to apply a receipt to them.

Below describes the components on the dialog.

![Opening Invoices and Credit Memos Dialog](image)

**Data Fields**

Under the 'Invoices' tab:

**Ref**: The reference number of the invoice.

**Date**: The Date of the invoice.

**Due Date**: When the invoice is due.

**Disc %**: The percentage discount for early payment.

**Disc Date**: The date before which cash discount will be given if payment is made.
**Total:** The total amount of the invoice.

**Amount Paid:** The amount that have been paid for this invoice.

**Discount:** The discount amount that has been given for this invoice.

**Closed:** Indicates whether this invoice has already closed. OneStep will automatically close the invoice once it is paid up.

Under the 'Credit Memos' tab:

**Ref:** The reference number of the credit memo.

**Date:** The date of the credit memo.

**Total:** The total amount of the credit memo.

**Amount Applied:** The amount that has already been applied.

**Discount:** The discount amount that has been given.

**Closed:** Indicate whether this credit memo has been closed. OneStep will automatically close the credit memo once its amount has been applied.
5 Purchase Processing

Purchase processing is a series of activities starting from sending purchase orders to your vendors, to receiving the goods and invoices. OneStep provides the necessary functions to support all these activities and manage all the records involved.

The diagram below depicts the documents found in purchase processing.

The arrows in the diagram indicate that you can convert from one document to the other. For example, if your vendor invoice you for a purchase order that you have sent him, you can ask OneStep to convert the purchase order to a purchase invoice for you. This will save you the trouble of re-entering all the data.

Take note that OneStep does not impose that you have to start your purchase process from purchase order; in fact, you can start your purchase process from any point except for goods received note. A goods received note has to be based on a particular purchase order.

**Note:** *Purchase Order and Goods Received Note are only available in the Professional Editions.*

The sections that follow will describe the each of the documents above.

5.1 Purchase Order *(Available In Professional Edition Only)*

When you purchase goods or services from your vendors, you send them a purchase order stating the goods and services required and other necessary information.

To work with purchase orders in OneStep, select Purchase→Orders from either the menu or the tool bar.

5.1.1 Purchase Order List Form

Below describes the components pertaining to the Purchase Order list form. Please refer to “Working with OneStep, List Form” for components not described here.
Data Fields

**Date:** The date of the purchase order.

**Order No:** The order’s reference number.

**Vendor:** The vendor’s name.

**Total:** The total amount of the order.

**Received:** Indicates whether the items of the order have been received.

**Closed:** Indicates whether the order has been closed.

### 5.1.2 Purchase Order Record Form

Below describes the components pertaining to the Purchase Order record form. Please refer to “Working with OneStep, Record Form” for components not described here.

Data Fields

**Vendor Account / Name:** The vendor’s account and name.

**Attn:** The person to attention to.
Date: Date of the order.

Order No: The reference number of the order. If this field is left blank, OneStep will automatically generate the next order number for you.

Remit To: The vendor’s address. OneStep will automatically fill in this field based on the vendor’s record when you complete the Vendor Account field.

Ship To: The address you want your vendor to ship the goods to. OneStep will automatically fill in this field based on the company’s record.

Tax Reg No: Vendor’s tax registration or ID number.

Your Ref: Vendor’s internal reference. If you have previously asked your vendor to give you a quotation then this could be the quotation number of the quotation.

Our Ref: Our internal reference.

Terms: The credit terms. OneStep will automatically fill in this field based on the vendor’s record when you complete the Vendor Account field.

Ship Date: If you require that the goods be shipped by a particular date, you can enter the date here.

Via: The method of transportation. For example, UPS, Fed Ex, etc.

FOB: Stands for “Free On Board”; refers to the point where freight is paid.

Item: Enter the item you want to include in the order here. If you leave this field blank then the line will become a comment line and you can enter your comment in the description field.

Description: Description of the item. OneStep will automatically fill in this field based on the item’s record when you complete the Item field.

Qty: The number of units you are buying for the item.

Received: The number of items that have been received. This value will be automatically updated when you include the item for this order in a goods received order.

Unit Price: The price per unit you are buying for the item. OneStep will automatically fill in this field based on the cost price value in the item record when you complete the item field. You can override this value if needed.

Amount: The total line amount that is calculated by multiplying Qty and Unit Price. OneStep will automatically calculate this value whenever the Qty or Unit Price changes.

Tax (on the item line): Check this field if the item line is to be included for computing the tax amount. OneStep will automatically fill in this field based on the item’s record when you complete the Item field.

Tax: The tax item used, the tax rate and the tax amount. OneStep will automatically fill in the tax item based on the preference record.

Calc. Tax After Discount (The Check Box Next To Tax Field): Check this if you want OneStep to calculate the tax amount based on the total amount less early payment discount.

Total: The total amount of the order. OneStep will automatically calculate this value for you.

Received: When all the items in the order have been received, this value is set to true automatically. You are not allowed to change the value manually.
**Closed:** You close a purchase order when you are no longer interested in it (usually because you have already received the goods and its corresponding invoice from your vendor or the order is canceled). OneStep will automatically close a purchase order when you convert it to a purchase invoice. You can also manually close a purchase order.

**Command Buttons**

- **Others → Create Goods Received Note:** Click this button to create a goods received note based on the order.
- **Others → Create Invoice:** Click this button to convert the order into a purchase invoice.
- **Others → Print Preview:** Click this button to save the order and preview the printout.
- **Others → Select Report Form:** Click this button to bring up the select report form dialog.
- **Others → Custom Fields:** Click this button to bring up the custom fields dialog to edit on the custom fields.
- **Print:** Click this button to print the purchase order.

**Edit Taxable Total:** If you add a tax item to the list of item lines then you can edit the taxable total of the tax item by right clicking on the item line and selecting the edit taxable total command.

### 5.2 Goods Received Note (Available In Professional Edition Only)

You use a goods received note to record the goods you received from your suppliers.

To work with goods received notes in OneStep, select Purchase → Goods Received Note from either the menu or the toolbar.

#### 5.2.1 Goods Received Note List Form

Below describes the components pertaining to the Goods Received Note list form. Please refer to “Working with OneStep, List Form” for components not described here.

#### Data Fields

- **Date:** The date of the goods received note.
GRN No: The goods received note’s reference number.

Vendor: The vendor’s name.

Status: Indicates whether you are expecting the goods or the goods have been received.

Closed: Indicates whether the goods received note has been closed.

5.2.2 Goods Received Note Record Form

Below describes the components pertaining to the Goods Received Note record form. Please refer to “Working with OneStep, Record Form” for components not described here.

[Image]: Goods Received Note record form.

Data Fields

Vendor: The name of your vendor. If the goods received note is converted from a purchase order, this field is automatically filled in by OneStep.

Date: Date of the goods received note.

GRN No: The reference number for the goods received note. You should enter the reference number of the goods received note your vendor sent you.

Purchase Order / Vendor Name: The purchase order of which the items are received in this goods received note and the vendor’s name on the purchase order. If the goods received note is converted from a purchase order, this field is automatically filled in by OneStep.

Status: Indicates whether you are expecting the goods to be shipped to you or you have already received the goods.

Remit To: The vendor’s address. OneStep will automatically fill in this field based on the vendor’s record when you complete the Vendor field.

Ship To: The address you want your vendor to ship the goods to. OneStep will automatically fill in this field based on the company’s record.

Ship Date: If the shipped date is different from the delivery order date than you can enter the date here.

Via: The method of transportation. For example, UPS, Fed Ex, etc.
Received By: The name of the person who received the items delivered.

Item: The Item you are receiving. You cannot directly edit on this field. You have to use the ‘Add’ function to add an item line to the goods received note.

Description: Description of the item. You cannot directly edit on this field. You have to use the ‘Add’ function to add an item line to the goods received note.

Remaining: The remaining quantity of the item of the associated purchase order that has yet to be received.

Qty: The number of units you are receiving for the item.

Remark (on item line): For you to add any remark to the item received.

Closed: You close a goods received note when you are no longer interested in it usually because you have already received a corresponding invoice for the goods received note or the goods received note is canceled. OneStep will automatically close a goods received note when you convert it to a purchase invoice. You can also manually close a goods received note.

Remark: Enter any remark for the goods received note here.

Command Buttons

Fill All: Click this button to fill all the items in the goods received note. That is, to set all the Qty values equal to their respective Remaining values.

Add: Click this button to call up a dialog for selecting items that have yet to be received for the selected purchase order.

Others→Create Invoice: Click this button to create a purchase invoice based on the goods received note.

Others→Custom Fields: Click this button to bring up the Custom Fields dialog to edit on the custom fields.

5.3 Purchase Invoice

Purchase invoice is for you to record the invoice you received from your suppliers for the goods and services they have supplied you with.

To work with purchase invoices in OneStep, select Purchase→Invoices from either the menu or the tool bar.

5.3.1 Purchase Invoice List Form

Below describes the components pertaining to the Purchase Invoice list form. Please refer to “Working with OneStep, List Form” for components not described here.
Data Fields

**Date**: The date of the invoice.

**Invoice No**: The invoice’s reference number.

**Vendor**: The vendor’s name.

**Due Date**: The due date of the invoice.

**Disc Date**: The discount date for early payment.

**Total**: The total amount of the invoice.

**Amt Due**: The amount outstanding, i.e. the amount you still owe the vendor for this invoice.

**Closed**: Indicates whether the invoice has been closed.

### 5.3.2 Purchase Invoice Record Form

Below describes the components pertaining to the Purchase Invoice record form. Please refer to “Working with OneStep, Record Form” for components not described here.
Data Fields

**Vendor Account / Name:** vendor’s account and name.

**Date:** Date of the invoice.

**Invoice No:** The reference number for the invoice. You should enter the reference number of the invoice your vendor sent you.

**Remit To:** The vendor’s address. OneStep will automatically fill in this field based on the vendor’s record when you complete the Vendor Account field.

**Ship To:** The address you want your vendor to ship the goods to. OneStep will automatically fill in this field based on the company’s record.

**Tax Reg No:** Vendor’s tax registration or ID number.

**Our Ref:** Our internal reference. If this invoice is converted from a purchase order, then this will be the purchase order’s number. If this invoice is converted from a goods received note, then this will be the goods received note’s reference number.

**Terms:** The credit terms. OneStep will automatically fill in this field based on the vendor’s record when you complete the Vendor Account field.

**Ship Date:** The date on which the goods are received.

**Via:** The method of transportation. For example, UPS, Fed Ex, etc.

**FOB:** Stands for “Free On Board”; refers to the point where freight is paid.

**Item:** Enter the item you want to include in the invoice here. If you leave this field blank then the line will become a comment line and you can enter your comment in the Description field.

**Description:** Description of the item. OneStep will automatically fill in this field based on the item’s record when you complete the Item field.

**Qty:** The number of units you are buying for the item.

**Unit Price:** The price per unit you are buying for the item. OneStep will automatically fill in this field based on the cost price value in the item record when you complete the Item field. You can override this value if needed.

**Amount:** The total line amount that is calculated by multiplying Qty and Unit Price. OneStep will automatically calculate this value whenever the Qty or Unit Price changes.

**Tax (on the item line):** Check this field if the item line is to be included for computing the tax amount. OneStep will automatically fill in this field based on the item’s record when you complete the Item field.

**Tax:** The tax item used, the tax rate and the tax amount. OneStep will automatically fill in the tax item based on the preference record.

**Calc. Tax After Discount (The Check Box Next To Tax Field):** Check this if you want to calculate the tax amount based on the total amount less early payment discount.

**Total:** The total amount of the invoice. OneStep will automatically calculate this value for you.

**Closed:** You close a purchase invoice when you are no longer interested in it (usually because you have already paid for the invoice). OneStep will automatically close a purchase invoice when it is fully paid for.
Command Buttons

Others→Payment History: Click this button to view the payment history for this invoice.

Others→Print Preview: Click this button to save the invoice and preview the printout.

Others→Select Report Form: Click this button to bring up the Select Report Form dialog.

Others→Due Date: Click this button to bring up the Due Date dialog to view or change the due date. Please note that the due date will be overridden whenever the invoice date or terms changes.

Others→Custom Fields: Click this button to bring up the Custom Fields dialog to edit on the custom fields.

Others:

Edit Taxable Total: If you add a tax item to the list of item lines then you can edit the taxable total of the tax item by right clicking on the item line and selecting the edit taxable total command.

5.4 Debit Memo

Sometimes, you are unsatisfied with the goods or services you received from your vendors, for example the goods are damaged, and you ask your vendor for a refund in credit or in cash. To account for the refund, you use a debit memo.

To work with debit memos in OneStep, select Purchase→Debit Memos from either the menu or the tool bar.

5.4.1 Debit Memo List Form

Below describes the components pertaining to the Debit Memo list form. Please refer to “Working with OneStep, List Form” for components not described here.

Data Fields

Date: The date of the debit memo.

Reference: The debit memo’s reference number.

Vendor: The vendor’s name.
Type: Indicates whether the debit memo is to debit account or a cash refund.

Total: The total amount of the debit memo.

Closed: Indicates whether the debit memo has been closed.

5.4.2 Debit Memo Record Form

Below describes the components pertaining to the Debit Memo record form. Please refer to “Working with OneStep, Record Form” for components not described here.

Data Fields

Vendor Account / Name: The vendor’s account and name.

Date: Date of the debit memo.

Memo No: The reference number for the debit memo. You should enter the reference number of the credit memo your vendor sent you.

Remit To: The vendor’s address. OneStep will automatically fill in this field based on the vendor’s record when you complete the Vendor Account field.

Type: Indicate whether the debit memo is to debit the vendor account or it is a cash refund from the vendor.

Deposit To: If the debit memo is a cash refund from the vendor, set this field to the account to which the cash refund is deposited.

Our Ref: Our internal reference. Usually, you should set this value to the invoice number of the invoice that the debit memo is associated to.

Payment Method: The method of payment. For example, cash or check, etc. Used only when the debit memo is for a cash refund.

Payment Ref: The payment’s reference number. For example, the check number, the visa card number, etc. Used only when the debit memo is for a cash refund.

Item: Enter the item you want to include in the memo here. If you leave this field blank then the line will become a comment line and you can enter your comment in the Description field.
**Description**: Description of the item. OneStep will automatically fill in this field based on the item’s record when you complete the Item field.

**Qty**: The number of units you are selling for the item.

**Unit Price**: The price per unit you set up for the item. OneStep will automatically fill in this field based on the cost price value in the item record when you complete the item field. You can override this value if needed.

**Amount**: The total line amount that is calculated by multiplying Qty and Unit Price. OneStep will automatically calculate this value whenever the Qty or Unit Price changes.

**Tax (on the item line)**: Check this field if the item line is to be included for computing the tax amount. OneStep will automatically fill in this field based on the item’s record when you complete the Item field.

**Tax**: The tax item used, the tax rate and the tax amount. OneStep will automatically fill in the tax item based on the preference record.

**Total**: The total amount of the debit memo. OneStep will automatically calculate this value for you.

**Closed**: You close a debit memo when you are no longer interested in it (usually because the debit amount of this debit memo has been applied). OneStep will automatically close a debit memo when its debit amount is fully applied.

**Command Buttons**

- **Others→Applied History**: Click this button to view the amount-applied history for this memo.
- **Others→Print Preview**: Click this button to save the memo and preview the printout.
- **Others→Select Report Form**: Click this button to bring up the Select Report Form dialog.
- **Others→Custom Fields**: Click this button to bring up the Custom Fields dialog to edit on the custom fields.

**Others**

**Edit Taxable Total**: If you add a tax item to the list of item lines then you can edit the taxable total of the tax item by right clicking on the item line and selecting the edit taxable total command.

### 5.5 **Cash Purchase**

To record purchases that you make payment at the point of purchase, you can use the cash purchase function in OneStep.

To work with cash purchase, select Purchase→Cash Purchase from either the menu or the tool bar.

### 5.5.1 **Cash Purchase List Form**

Below describes the components pertaining to the Cash Purchase list form. Please refer to “Working with OneStep, List Form” for components not described here.
Data Fields

**Date**: The date of the cash purchase.

**Reference**: The cash purchase’s reference number.

**Vendor**: The vendor’s name.

**Total**: The total amount of the cash purchase.

### 5.5.2 Cash Purchase Record Form

Below describes the components pertaining to the Cash Purchase record form. Please refer to “Working with OneStep, Record Form” for components not described here.

Data Fields

**Vendor Account / Name**: The vendor’s account and name. This field is optional since for cash purchase you may not need to record the vendor’s details.

**Date**: Date of the cash purchase.
Reference: The reference number for the cash purchase. You should enter the reference number of the receipt you get from your vendor.

Remit To: The vendor’s address. OneStep will automatically fill in this field based on the vendor’s record when you complete the Vendor Account field.

Ship To: The address you want your vendor to ship the goods to. OneStep will automatically fill in this field based on the company’s record.

Tax Reg No: Vendor’s tax registration or ID number.

Payment Method: The method of payment. For example, cash or check, etc.

Payment Ref: The payment’s reference number. For example, the check number, the visa card number, etc.

Ship Date: The date on which the goods are to be shipped.

Via: The method of transportation. For example, UPS, Fed Ex, etc.

FOB: Stands for “Free On Board”; refers to the point where freight is paid.

Item: Enter the item you want to include in the purchase here. If you leave this field blank then the line will become a comment line and you can enter your comment in the description field.

Description: Description of the item. OneStep will automatically fill in this field based on the item’s record when you complete the Item field.

Qty: The number of units you are selling for the item.

Unit Price: The price per unit you for the item. OneStep will automatically fill in this field based on the cost price value in the item record when you complete the Item field. You can override this value if needed.

Amount: The total line amount that is calculated by multiplying Qty and Unit Price. OneStep will automatically calculate this value whenever the Qty or Unit Price changes.

Tax (on the item line): Check this field if the item line is to be included for computing the tax amount. OneStep will automatically fill in this field based on the item’s record when you complete the Item field.

Tax: The tax item used, the tax rate and the tax amount. OneStep will automatically fill in the tax item based on the preference record.

Total: The total amount of the cash purchase. OneStep will automatically calculate this value for you.

Pay From: Set this to the account where the money for the purchase is paid from.

Command Buttons

Others→Print Preview: Click this button to save the memo and preview the printout.

Others→Select Report Form: Click this button to bring up the Select Report Form dialog.

Others→Custom Fields: Click this button to bring up the Custom Fields dialog to edit on the custom fields.

Others

Edit Taxable Total: If you add a tax item to the list of item lines then you can edit the taxable total of the tax item by right clicking on the item line and selecting the edit taxable total command.
5.6 Vendor

You can create vendor records using the vendor function in OneStep. To work with vendor records, select Purchase→Vendors from either the menu or the tool bar.

5.6.1 Vendor List Form

Below describes the components pertaining to the Vendor list form. Please refer to “Working with OneStep, List Form” for components not described here.

![Vendor List Form]

Data Fields

Name: The vendor’s name.

Credit Limit: The maximum credit limit the vendor would extend to you.

Balance: The total amount you owe the vendor.

Command Buttons

Print Account Journal: Click this button to bring up Print Account Journal window for printing of vendor account journal.

5.6.2 Vendor Record Form

Below describes the components pertaining to the Vendor record form. Please refer to “Working with OneStep, Record Form” for components not described here.
Data Fields

**Name:** The name of the vendor

**Printed Name:** The name to be used when the vendor’s name is printed.

**Active:** Indicates whether the vendor is still active. Inactive vendors will not appear in the vendor selections for purchases.

Under the 'Company' tab:

**Contact:** The contact person.

**Phone:** The vendor’s phone number.

**Fax:** The vendor’s fax number.

**Address:** The vendor’s address.

Under the 'Account' tab:

**Control Account:** The payable account in general ledger to which the vendor should be grouped.

**Credit Limit:** The credit amount that your company is allowed by the vendor.

**Terms:** The credit terms this vendor extends to you.

**Tax:** The tax item associated with this vendor

**Calc. Tax After Discount (The Check Box Next To Tax Field):** Check this if you want OneStep to calculate the tax amount based on the total amount less early payment discount.

**Tax Registration No:** The tax registration or ID number of this vendor.

**Balance:** The account balance of the vendor. That is, the amount you owe this vendor.

Under the 'Custom Fields' tab:

**Field 1 to Field 5:** These are the fields that you can use to record additional data required for the vendor

Under the 'Memo 1' to 'Memo 3' tab:

**80 Purchase Processing**
Memo Fields: Just like custom fields, the memo fields are for you to record additional data for the vendor. However, unlike custom fields there is no restriction to the number of characters you can enter to these fields.

Command Buttons

Openings …: Click this button to call up the opening invoices and debit memo dialog for entering outstanding opening invoices and credit memos that have been posted when you first set up OneStep.

5.6.3 Opening Invoices and Debit Memos Dialog

This dialog allows you to enter outstanding purchase invoices and debit memos that you have already posted to your accounts but are not yet close when you switch over to OneStep (Please note that OneStep will not post these transactions). OneStep will use this information to compute the aging report as well as allow you to apply a receipt to them.

Below describes the components on the dialog.

Data Fields

Under the 'Invoices' tab:

Ref: The reference number of the invoice.

Date: The Date of the invoice.

Due Date: When the invoice is due.

Disc %: The percentage discount for early payment.

Disc Date: The date before which cash discount will be given if payment is settled.

Total: The total amount of the invoice.

Amount Paid: The amount that have been paid for this invoice.

Discount: The discount amount that has been given for this invoice.

Closed: Indicates whether this invoice has already closed. OneStep will automatically close the invoice once it is paid up.
Under the 'Debit Memos' tab:

**Ref**: The reference number of the debit memo.

**Date**: The date of the credit memo.

**Total**: The total amount of the credit memo.

**Amount Applied**: The amount that has been already applied.

**Discount**: The discount amount that has been given.

**Closed**: Indicates whether this credit memo has been closed. OneStep will automatically close the credit memo once its amount has been applied.
6 Cash Management

The cash management functions in OneStep give you the ability to handle receipts and payments.

6.1 Cash Receipt

To record payments you received either from your customers for outstanding invoices or from other parties, you can use the cash receipt function in OneStep.

To work with cash receipts, select Cash ➔ Cash Receipts from either the menu or the tool bar.

6.1.1 Cash Receipt List Form

Below describes the components pertaining to the Cash Receipt list form. Please refer to “Working with OneStep, List Form” for components not described here.

Data Fields

Date: The date of the receipt.

Receipt No: The receipt’s reference number.

From: The account from which you received payment.

Amount: The amount received.

6.1.2 Cash Receipt Record Form

When you receive a payment, it could be from your customer who is paying you to settle the amount of its outstanding invoices or it could be from some other parties. OneStep shows a slightly different record form for the different parties you are receiving the payment from.

Below describes the components pertaining to the Cash Receipt Record Form. Please refer to “Working with OneStep, Record Form” for components not described here.

If you are receiving from your customer
If you are receiving from your vendor

If you are receiving from other parties

Data Fields

84  Cash Management
From: The type of account which the payment is received from.

Date: Date of the receipt

Receipt No: The reference number of the receipt. If this field is left blank, OneStep will automatically generate the next number for you.

Account: The account from which the payment is received. Applicable only to payments from customer and vendor account only.

Balance: The balance of the account from which the payment is received.

Amount: The amount received on this receipt.

Received From: The name of the company/person who you received payment from.

Addr/Attn: Click this button to view/edit the person to attention to and the address of the party who you received payment from.

Description: Description of the receipt if any.

Payment Method: The method of payment. For example, cash or cheque, etc.

Payment Ref: The payment’s reference number. For example, the cheque number, the visa card number, etc.

Deposit To: The account to deposit the payment to.

Discount Account: The account to which the discount amount is to be posted. Applicable only to payments from customer account only.

Exch. Gain/ Loss: Allows you to specify the Exch. Gain/ Loss account and the corresponding Exch. Gain/ Loss amount for the receipt. Applicable only to payments from customer account only.

Closed?: To indicate whether the receipt amount is fully applied. When the receipt amount is fully applied, it will not appear as an open item in the customer statement. OneStep will automatically check this when the payment amount + exchange gain/loss amount is greater or equal to the receipt amount. Applicable only to payments from customer account only.

Disc: The sum of all the discount amounts. Applicable only to payments from customer account only.

Pmt: The sum of all the payment amounts. Applicable only to payments from customer account only.

Data Fields For Outstanding Invoices And Credit Memos

(Apply only to payment received from customer. The entries in the list are to allow you to knock off the invoices or credit memos of the customer.)

Date: The date of the invoice or memo.

Type: The type of source documents. SI – Sales Invoice, CM – Credit Memo.

Ref: The reference number of the source document.

Total: The total amount of the source document.

Due Date: The due date of the source document. Applicable only to sales invoice.

Cash Management  85
Amount Due: The outstanding amount of the source document.

Disc Date: The date on and before which discount will be given. Applicable only to sales invoices.

Disc %: The discount percentage. Applicable only to sales invoice.

Discount: The discount amount given to the associated source document.

D: OneStep will automatically fill in or clear the discount amount when you check and uncheck this field.

Payment: The amount paid or applied to the associated source document in this cash receipt.

P: OneStep will automatically fill in or clear the payment amount when you check and uncheck this field.

Data Fields For Distribution

(Apply only to payment received from other account. The entries in the list allow you to distribute the amount received to various accounts.)

Account: A general ledger account.

Description: Description of the amount charged to the general ledger account.

Amount: The amount charged to the general ledger account.

If the general ledger account is a tax account, OneStep allows you to track the tax details using the Tax, Tax Type and Taxable Total fields. It is important that you edit these fields accordingly if you want OneStep to track for you all your taxable purchases and sales.

Tax: The associated tax item.

Tax Type: Either Sales or Purchase.

Taxable Total: The taxable total from which the tax amount is based.

Command Buttons

Add: Click this button to add the outstanding invoices and memos from a selection list.

Others→Print Preview: Click this button to save the receipt and preview the printout.

Others→Select Report Form: Click this button to bring up the Select Report Form dialog.

Others→Custom Fields: Click this button to bring up the Custom Fields dialog to edit on the custom fields.

Print: Click this button to save and print the receipt.

6.2 Cash Disbursement

To record the payment you make to either your vendors for outstanding invoices or to other parties, you can use the cash disbursement function in OneStep.

To work with cash disbursements, select Cash→Cash Disbursements from either the menu or the tool bar.

6.2.1 Cash Disbursement List Form
Below describes the components pertaining to the Cash Disbursement List Form. Please refer to “Working with OneStep, List Form” for components not described here.

### Data Fields

**Date**: The date of the disbursement.

**Disburse No**: The reference number of the disbursement.

**Pay To**: The name of the company or person to which the disbursement is made.

**Amount**: The disbursement’s amount.

### 6.2.2 Cash Disbursement Record Form

When you make a payment, it could be to your vendor for settling the amount of your outstanding invoices or it could be to some other parties. OneStep shows a slightly different record form for the different parties you are making the payment to.

Below describes the components pertaining to the Cash Disbursement record form. Please refer to “Working with OneStep, Record Form” for components not described here.

If you are paying to your vendor

If you are paying to your customer
If you are paying to other parties

Data Fields

**To:** The type of account which the payment is made to.

**Date:** Date of the payment

**Disbursement No:** The reference number of the disbursement. If this field is left blank, OneStep will automatically generate the next number for you.

**Account:** The account to which the payment is made. Applicable only to payment made to customer and vendor account.

**Pay To:** The company/person this payment is paid to.

**Addr/Attn:** Click this button to view/edit the person to attention to and the address of the party that the payment is paid to.

**Balance:** The balance of the account to which the payment is made.

**Amount:** The amount paid in this payment.
**Description:** Description of the payment if any.

**Payment Method:** The method of payment. For example, cash or check, etc.

**Payment Ref:** The payment’s reference number. For example, the check number, the visa card number, etc.

**Pay From:** The account from which the money for the payment is withdrawn.

**Discount Account:** The account to which the discount is to be posted. Applicable only for payment is made out to vendor account.

**Exch. Gain/ Loss:** Allows you to specify the Exch. Gain/Loss account and the corresponding Exch. Gain/Loss amount upon cash disbursement. Applicable only for payment is made out to vendor account.

**Closed?:** To indicate whether the disbursement amount is fully applied. OneStep will automatically check this when the payment amount - exchange gain/loss amount is greater or equal to the disbursement amount. Applicable only for payment is made out to vendor account.

**Disc:** The sum of all the cash discount amounts. Applicable only for payment is made out to vendor account.

**Pmt:** The sum of all the payment amounts. Applicable only for payment is made out to vendor account.

**Data Fields For Outstanding Invoices And Debit Memos**

(Apply only to payment made to vendor. The entries in the list are to allow you to knock off the invoices or debit memos from the vendor.)

**Date:** The date of the invoice or memo.

**Type:** The type of source documents. PI – Purchase Invoice, DM – Debit Memo.

**Ref:** The reference number of the source document.

**Total:** The total amount of the source document.

**Due Date:** The due date of the source document. Applicable only to purchase invoice.

**Amount Due:** The outstanding amount of the source document.

**Disc Date:** The date on and before which a cash discount will be given. Applicable only to purchase invoice.

**Disc %:** The discount percentage. Applicable only to purchase invoice.

**Discount:** The discount amount given to the associated source document.

**D:** OneStep will automatically fill in or clear the discount amount when you check or uncheck this field.

**Payment:** The amount paid or applied to the associated source.

**P:** OneStep will automatically fill in or clear the payment amount when you check or uncheck this field.

**Data Fields For Expense Distribution**

(Apply only to payment made to other account. The entries in the list allow you to distribute the amount paid to various accounts.)
**Account**: A general ledger account.

**Description**: Description of the amount charged to the general ledger account.

**Amount**: The amount charged to the general ledger account.

If the general ledger account is a tax account, OneStep allows you to track the tax detail by using the Tax, Tax Type and Taxable Total fields. It is important that you edit these fields accordingly if you want OneStep to track all your taxable purchases and sales.

**Tax**: The associated tax item.

**Tax Type**: Either Sales or Purchase.

**Taxable Total**: The taxable total from which the tax amount is based.

**Command Buttons**

**Add**: Click this button to add the outstanding invoices and memos from a selection list.

**Others → Print Preview**: Click this button to save the disbursement and preview the printout.

**Others → Select Report Form**: Click this button to bring up the Select Report Form dialog.

**Others → Custom Fields**: Click this button to bring up the Custom Fields dialog to edit on the custom fields.

**Print**: Click this button to save and print the disbursement.
7 Items Management

Items are services or products that you buy and sell. In OneStep, besides the item that you buy and sell, you can also add items that represent discounts, subtotal, tax items and comments.

The items management functions in OneStep give you the ability to create new items, build/unbuild assemblies, perform adjustment to the items’ inventory, set custom pricing, etc.

7.1 Item

You can create item records using the item function in OneStep. To work with item records, select Item→Items from either the menu or the tool bar.

7.1.1 Item List Form

Below describes the components pertaining to the Item list form. Please refer to “Working with OneStep, List Form” for components not described here.

Data Fields

Item: The name of the item.

Type: The item’s type.

Description: The description of the item.

On Hand: The quantity on-hand.

Balance: The dollar amount of the on-hand items.

Command Buttons

Print Account Journal: Click this button to bring up Print Account Journal window for printing of item account journal.

7.1.2 Item Record Form

Below describes the components pertaining to the Item record form. Please refer to “Working with OneStep, Record Form” for components not described here.
Data Fields

**Name:** The name or code that uniquely identify the item.

**Active:** Indicates whether the item is still active. Inactive items will not appear in the item selection list for purchases and sales.

**Type:** The item’s type. There are nine different types of items supported by OneStep.

<table>
<thead>
<tr>
<th>Type</th>
<th>Use For</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assembly</td>
<td>Items that are made up of other items.</td>
</tr>
<tr>
<td>Comment</td>
<td>A message.</td>
</tr>
<tr>
<td>Inventory Product</td>
<td>Products that you track as inventory.</td>
</tr>
<tr>
<td>Non-Inventory Product</td>
<td>Products that you do not track as inventory.</td>
</tr>
<tr>
<td>Other</td>
<td>Items that do not belong to other categories.</td>
</tr>
<tr>
<td>Percentage</td>
<td>Items that are calculated in percentage term like percentage discounts, etc.</td>
</tr>
<tr>
<td>Service</td>
<td>Services you charge for or services you purchase.</td>
</tr>
<tr>
<td>Subtotal</td>
<td>Calculate the sum of all amounts before this item.</td>
</tr>
<tr>
<td>Tax</td>
<td>Items for tax purposes. Like GST, VAT, etc.</td>
</tr>
</tbody>
</table>

Under the 'Item' tab:

**Description:** The description of the item. What you enter here would appear under the description column of the sales or purchases form when you sell or purchase the items. You can have multiple lines of description however the total length of the description must not be more than 255 characters.

**Sales Price:** The value to be displayed as the unit price of this item for sales.

**Cost Price:** The value to be displayed as the unit price of the item for purchases. If the item is an assembly, then the cost price is the sum of the cost prices of all the items it is made up of. This value will also be used to compute the Cost of Goods in the event that you sell an item whose quantity is zero or negative.
**Percentage**: The percentage value when the item type is Percentage or Tax. If you are creating a percentage discount, remember to set the percentage value to a negative value.

**Taxable**: To indicate whether this is a taxable item. A taxable item is included for tax calculation in a sales or purchase.

**Preferred Vendor**: The preferred vendor for this item.

Under the 'Inventory' tab:

**Cost Method**: The method for computing cost of goods when the item is sold. OneStep supports Average Cost, First In First Out (FIFO) and Last In First Out (LIFO) methods.

**Min Qty**: The minimum quantity of the item to be maintained.

**Reorder Qty**: The economic order quantity you should reorder once the minimum quantity has been reached.

**Qty On Hand**: The quantity of the item on hand.

Under the 'Account' tab:

**Control Account**: The inventory account in general ledger to which the item should be grouped. Applicable only to inventory Product.

**Balance**: The total dollar amount of the item on hand. Applicable only to inventory product.

**Posting Account (Sales)**: The posting account for sales.

**Posting Account (Sales Return)**: The posting account for sales return.

**Posting Account (Purchase)**: The posting account for purchase.

Under the 'Bill of Material' tab:

**Part Name**: The name of the item to be included as part of the assembly.

**Part Description**: The description of the item to be included as part of the assembly.

**Qty**: The quantity of the part needed to build one assembly item.

Under the 'Stock Card' tab:

This tab displays the stock queue information in the order of older to newer stock. batch

**Qty**: The quantity of the stock batch

**COG**: The cost of the stock batch.

**COG/QTY**: The unit price of each item in the stock batch. Unit Price = COG/QTY.

Under the 'Custom Fields' tab:

**Field 1 to Field 5**: These are the fields that you can use to record additional data required for the item

### 7.2 Inventory Adjustment
Sometimes you need to make changes to the on-hand quantities of inventory items for damages, loss or other reasons. To record for this, you can use the inventory adjustment function in OneStep.

To work with inventory adjustments, select Item→Inventory Adjustments from either the menu or the tool bar.

### 7.2.1 Inventory Adjustment List Form

Below describes the components pertaining to the Inventory Adjustment list form. Please refer to “Working with OneStep, List Form” for components not described here.

**Data Fields**

- **Date**: The date of the inventory adjustment.
- **Adjustment No**: The adjustment’s reference number.
- **Description**: The description of the adjustment.

### 7.2.2 Inventory Adjustment Record Form

Below describes the components pertaining to the Inventory Adjustment record form. Please refer to “Working with OneStep, Record Form” for components not described here.

**Data Fields**

- **Adjustment No**: The reference number of the adjustment. If this field is left blank, OneStep will automatically generate the next number for you.
Date: The date of the adjustment.

Description: A description for the adjustment.

Adjustment Account: The general ledger account to which to offset the inventory account adjustments.

Item: The item to be adjusted.

Qty: The quantity of the item to be adjusted. Enter a positive value to increase the on hand quantity of the item else enter a negative value to decrease the on-hand quantity of the item.

Cost of Goods: The dollar amount of the adjusted items. If you are increasing the on-hand quantity of the item, you have to provide this value. If you are decreasing the on-hand quantity of the item, you can either leave the field as zero dollar or fill in a value. If you leave it as zero dollar, OneStep will use the cost method of the item to decrease its inventory amount. If you fill in a value, OneStep will use the provided amount to decrease its inventory amount.

Command Buttons

Others→Print Preview: Click this button to save the memo and preview the printout.

Others→Select Report Form: Click this button to bring up the Select Report form dialog.

7.3 Build / Unbuild Assembly

You can build and unbuild assemblies using the Build/Unbuild assembly function in OneStep. To work with build/unbuild assembly, select Item->Build/Unbuild Assemblies from either the menu or the tool bar.

7.3.1 Build/Unbuild Assembly List Form

Below describes the components pertaining to the Build/Unbuild Assembly list form. Please refer to “Working with OneStep, List Form” for components not described here.

Data Fields

Date: The date of the build/unbuild.

Build No: The reference number of the build/unbuild.

Item: The item in the build/unbuild.
Description: The description of the build/unbuild.

7.3.2 Build/Unbuild Assembly Record Form

Below describes the components pertaining to the Build/Unbuild Assembly record form. Please refer to “Working with OneStep, Record Form” for components not described here.

Data Fields

Build No: The reference number of the build/unbuild. If this field is left blank, OneStep will automatically generate the next number for you.

Date: The date of the build/unbuild.

Description: A description for the build/unbuild.

Item: The item to be built or unbuilt.

Qty: The quantity of the item to be built or unbuilt. Enter a positive value to build and a negative value to unbuild.

Command Buttons

Others→Print Preview: Click this button to save the memo and preview the printout.

Others→Select Report Form: Click this button to bring up the Select Report Form dialog.

7.4 Price Group

OneStep allows you to set up custom pricing by assigning customers to different price groups and defining different sales prices for these price groups in the Sales Price Tables.

To work with price groups, select Item→Price Groups from either the menu or the tool bar.

7.4.1 Price Group List Form

Below describes the components pertaining to the Price Group list form. Please refer to “Working with OneStep, List Form” for components not described here.
Data Fields

**Name**: The name of the price group.

**Description**: The description of the price group.

### 7.4.2 Price Group Record Form

Below describes the components pertaining to the Price Group record form. Please refer to “Working with OneStep, Record Form” for components not described here.

Data Fields

**Name**: The name of the price group.

**Description**: The description of the price group.

### 7.5 Price Table

OneStep lets you to set up custom pricing for your customers through the use of price tables and price groups. You can assign your customers to different price groups and define different volume-based pricing for these price groups in the price tables. OneStep allows you to edit up to 3 price tables only.

To work with price tables, select Item→Price Tables from either the menu or the tool bar.

#### 7.5.1 Price Table List Form

Below describes the components pertaining to the Price Table list form. Please refer to “Working with OneStep, List Form” for components not described here.
Data Fields

**Name:** The name of the price table.

**Description:** The description of the price table.

7.5.2 Price Table Record Form

Below describes the components pertaining to the Price Table record form. Please refer to “Working with OneStep, Record Form” for components not described here.

**Data Fields**

**Name:** The name of the price table.

**Description:** The description of the price table

**Item:** The name of the item.

**Price Group:** The name of the price group.

**Sales Price:** The sales price of the item. OneStep will automatically fill in the field with the sales price from the item record once you complete the Item field.

**Min Qty:** The minimum purchase quantity required to qualify for the custom price.
**Price:** The custom item’s price

**Selection Bar**

**Search:** Type in the first few character of the product that you want to locate and OneStep will locate the record for you.

**Filter:** Click here to call up a filter form for you to restrict the records that appear. Please see “Working with OneStep, Filter Form” for more information.

**Command Buttons**

**Print:** Click this button to print the price table.

**Print Preview:** Click this button to preview the printing of the price table.

**Refresh:** Click this button to refresh the data of the price table.
8 General Ledger

The general ledger functions let you set up your general ledger accounts, enter general journal entries as well as perform reconciliations for bank accounts.

8.1 General Journal

When you need to record transactions that are not supported by any other documents in OneStep, you can use the general journal.

To work with general journal entries, select GL → General Journal from either the menu or the tool bar.

8.1.1 General Journal Entry List Form

Below describes the components pertaining to the General Journal Entry list form. Please refer to “Working with OneStep, List Form” for components not described here.

![General Journal Entry List Form]

Data Fields

Date: The date of the journal entry.

GJ No: The journal entry’s reference number.

Description: The description of the journal entry.

8.1.2 General Journal Entry Record Form

Below describes the components pertaining to the General Journal Entry record form. Please refer to “Working with OneStep, Record Form” for components not described here.
Data Fields

**GJ No:** The reference number of the journal entry. If this field is left blank, OneStep will automatically generate the next number for you.

**Date:** The date of the journal entry.

**Description:** The description of the journal entry.

**Account Type:** The type of account.

**Account:** The name of the account.

**Description (Line):** The description of the entry line.

**Debit:** The debit amount.

**Credit:** The credit amount.

If the general ledger account is a tax account, OneStep allows you to track the tax detail using the Tax, Tax Type and Taxable Total fields. It is important that you edit these fields accordingly if you want OneStep to track for you all your taxable purchases and sales.

**Tax:** The associated tax item.

**Tax Type:** Either Sales or Purchase.

**Taxable Total:** The taxable total from which the tax amount is based.

Command Buttons

**Set All:** Click this button to set all the lines’ descriptions to be the same as the journal entry’s description.

**Ok:** Click this button to save the general journal entry. OneStep will make sure that the sum of the debit amounts equals to the sum of the credit amounts before you are allowed to save the entry.

**Others ➔ Print Preview:** Click this button to save the memo and preview the printout.

**Others ➔ Select Report Form:** Click this button to bring up the Select Report Form dialog.
8.2 General Ledger Account

In OneStep, you manage your general ledger account using the general ledger functions.

To work with general ledger accounts, select GL \rightarrow General Ledger from either the menu or the tool bar.

8.2.1 General Account List Form

Below describes the components pertaining to the General Account list form. Please refer to “Working with OneStep, List Form” for components not described here.

8.2.2 Data Fields

Name: The name of the account or account group.

Balance: The balance amount of the account or account group.

Command Buttons

Print Account Journal: Click this button to bring up Print Account Journal window for printing of general ledger account journal.

8.2.3 General Account Record Form

Below describes the components pertaining to the General Account record form. Please refer to “Working with OneStep, Record Form” for components not described here.
Account List

On the left-hand side of the form is a list showing all the general accounts. As an alternative to the navigator at the bottom of the form, you can use the list to move from record to record.

Data Fields

Name: The name of the general ledger account.

Description: The description of the account.

Is Group: Select ‘Yes’, if you are creating an account group.

Sub-Account Of: Set this field to the account group under which you want to group this account.

Position: The position of this account under its account group. The position for the account will affect the order in which the account appears in the account list under the account group among the other accounts under the same group.

Type: This field represents the account type for the account. Normally, you do not need to set the field because it is filled automatically according to the account group the account belongs to. However, in the case where you want to change it to other account type (e.g. to define an account receivable account), you can change this field to use the appropriate type.

Below is a list of the available account types and their uses.

<table>
<thead>
<tr>
<th>Type</th>
<th>Used For</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asset</td>
<td>Accounts under the Assets heading of a balance sheet. Usually used for keeping track of the assets owned by the company.</td>
</tr>
<tr>
<td>Liability</td>
<td>Accounts under the Liabilities heading of a balance sheet. Usually used for keeping track of the debts and obligations the company.</td>
</tr>
<tr>
<td>Equity</td>
<td>Accounts under the Equity heading of a balance sheet. Usually used for keeping track of the owners’ claim of the assets of the company. It is the difference between the company’s liabilities and assets</td>
</tr>
<tr>
<td>Income</td>
<td>Accounts under the Income heading of a profit and loss statement. Usually used for keeping track of the company’s earnings</td>
</tr>
<tr>
<td>Cost of Sales</td>
<td>Accounts under the Cost of Sales heading of a profit and loss statement. Usually used for keeping track of the cost of goods sold to produce sales.</td>
</tr>
<tr>
<td>Expense</td>
<td>Accounts under the Expenses heading of a profit and loss statement. Usually used for keeping track of the operating expenses.</td>
</tr>
<tr>
<td>---------</td>
<td>------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Other Income</td>
<td>Accounts under the Other Incomes heading of a profit and loss statement. Usually used for keeping track of revenues earned from non-operating transaction.</td>
</tr>
<tr>
<td>Other Expense</td>
<td>Accounts under the Other Expenses heading of a profit and loss statement. Usually used for keeping track of expenses incurred from non-operating transactions.</td>
</tr>
<tr>
<td>Account Receivable</td>
<td>Control accounts for customers</td>
</tr>
<tr>
<td>Account Payable</td>
<td>Control accounts for vendors</td>
</tr>
<tr>
<td>Inventory</td>
<td>Control accounts for inventory items.</td>
</tr>
<tr>
<td>Bank</td>
<td>Bank accounts of the company. Similar to asset accounts except OneStep provides with a function for you to reconcile the transaction records of these accounts with the records you obtained from the banks.</td>
</tr>
</tbody>
</table>

### 8.3 Reconciliation

OneStep allows you to reconcile your banks’ statements with the records in OneStep.

To reconcile your bank account’s records, select GL→Reconciliation from either the menu or the tool bar.

Below describes the components on the Reconciliation form.

#### Data Fields

**Bank Name**: The name of your bank account.

**Opening Balance**: The sum of all previously cleared entries. OneStep will automatically compute this amount.

**Ending Balance**: Enter the ending balance shown on your bank statement here.

**Amount Cleared**: The sum of all entries cleared in this reconciliation.

**Difference**: Equals to Ending Balance – (Opening Balance + Amount Cleared). When the difference is 0.00, you have reconciled the account.

**Date**: Date of the receipt or payment.
**Remark**: A remark of the receipt or payment. Usually shows the payment method and the payment reference number.

**Receipt**: The amount received.

**Payment**: The amount paid.

**Clr**: Click here to reconcile (a.k.a. clear) the receipt or payment.

**Command Buttons**

**Select All**: Click this button to check (a.k.a. clear) all the entries in the list.

**Unselect All**: Click this button to uncheck all the entries in the list.

**Refresh**: Click this button to reload the data.

**Ok**: Click this button to save the reconciliation. You can only save the reconciliation when the Difference field is equal to $0.00.

**Cancel**: Click this button to cancel the changes and close the form.
9 Reports

Below describes the various types of reports available in OneStep.

9.1 Trial Balance

A trial balance is a list of general ledger accounts and their balances at a given time.

To view the trial balance, select Report→Trial Balance from either the menu or the tool bar and click on the Compute button of the Trial Balance window.

Below describes the selection fields and the command buttons on the Trial Balance window.

<table>
<thead>
<tr>
<th>Selection Fields</th>
<th>Command Buttons</th>
</tr>
</thead>
<tbody>
<tr>
<td>As Of: This field lets you select the ‘As Of’ date for the trial balance from a set of pre-defined dates.</td>
<td>Print: Click this button to print the report.</td>
</tr>
<tr>
<td>Date: The actual ‘As Of’ date for the trial balance. You can set this field to any date you want to have a snapshot of your general ledger accounts balances.</td>
<td>Preview: Click this button to preview the printing of the report.</td>
</tr>
<tr>
<td></td>
<td>Compute: Click this button to compute the report.</td>
</tr>
<tr>
<td></td>
<td>Close: Click this button to close the form.</td>
</tr>
</tbody>
</table>
9.2 Profit and Loss Statement

The profit and loss statement shows you whether your company is making a profit or not over a specific period of time.

To view the profit and loss statement, select Report→Profit & Loss from either the menu or the tool bar and click on the Compute button of the Profit and Loss Statement window.

Below describes the selection fields and the command buttons on the Profit and Loss Statement window.

![Profit and Loss Statement window]

### Selection Fields

**First Column:** This field lets you select a specific period for the generation of the profit and loss statement from a set of pre-defined periods.

**From Date:** This field lets you specify the starting date of a specific period for the generation of the profit and loss statement.

**To Date:** This field lets you specify the ending date of a specific period for the generation of the profit and loss statement.

**Second Column:** This field lets you select the data to be displayed on the second column of the profit and loss statement, usually serve as a comparison to the first column.

### Command Buttons

**Print:** Click this button to print the report.

**Preview:** Click this button to preview the printing of the report.

**Compute:** Click this button to compute the report.

**Close:** Click this button to close the form.
9.3 **Balance Sheet**

Balance Sheet is a statement that summarizes the financial position of a business. It shows the value of the business’ assets, liabilities, and equity as of a date.

To view the balance sheet statement, select Report→Balance Sheet from either the menu or the tool bar and click on the Compute button of the Balance Sheet window.

Below describes the selection fields and the command buttons on the Balance Sheet window.

![Balance Sheet Window](image)

**Selection Fields**

**First Column**: This field lets you select the ‘As Of’ date for the first column of the balance sheet from a set of predefined dates.

**Second Column**: This field lets you select the ‘As Of’ date for the second column of the balance sheet from a set of pre-defined dates.

**As Of**: The actual ‘As Of’ date for first and second column of the balance sheet.

**Command Buttons**

**Print**: Click this button to print the report.

**Preview**: Click this button to preview the printing of the report.

**Compute**: Click this button to compute the report.

**Close**: Click this button to close the form.

9.4 **Taxable Journal**
The taxable journal lists all the sales and purchases tax over a period of time you specify. It also shows you the taxable total and the tax total for the period.

To view the taxable journal, select Report → Taxable Journal from either the menu or the tool bar and click on the Refresh button of the Taxable Journal window after specifying the required date range.

Below describes the components on the Taxable Journal window.

### Selection Fields

**Dates:** This field lets you select the date range of the transactions that you are interested in.

**From Date:** The starting date of the date range.

**To Date:** The ending date of the date range.

**Tax:** The tax item you are interested in.

**Type:** The tax type, either Sales or Purchase.

### Data Fields

**Date:** The date of the transaction.

**Source:** The source document’s type of the transaction.

**Ref:** The source document’s reference number.

**Description:** The description of the transaction.

**Taxable:** The taxable amount.

**Tax:** The taxed amount.

### Summary

**Taxable Total:** The sum of all the taxable amounts.

**Tax Total:** The sum of all the taxed amounts.
Command Buttons

**Print**: Click this button to print the journal.

**Preview**: Click this button to preview the printing of the journal.

**Refresh**: Click this button to re-fetch the data.

**Close**: Click this button to close the form.

### 9.5 Transactions Log

This report shows you the transactions recorded by OneStep.

To view the transactions log, select **Report → Transactions** from either the menu or the tool bar and click on the Refresh button of the Transactions Log window after specifying the required date range...

Below describes the components on the Transactions window.

#### Selection Fields

**Dates**: This field lets you select the relevant range of dates for the transactions that you are interested in.

**From Date**: The starting date of the date range.

**To Date**: The ending date of the date range.

**Show Current Only**: Check this to see only the current transactions.

#### Transactions

This is a list of transactions that have taken place in the period you specified. To view the source document of a transaction, double click on the transaction itself or right click on the transaction and select the Source Document command.

**Date**: The date of the transaction.
Id: The transaction’s id number. Each transaction has a unique id number.

Ver: The transaction’s version number. Every time a transaction is updated, its version number will be incremented.

Status: Indicates whether the transaction is a current, previous or deleted record.

Last Modified: The date when the transaction is updated.

Source Type: The type of the source document of this transaction.

Source Ref: The reference number of the source document of this transaction.

Description: The description of the transaction.

User Id: The user id of the user who perform this transaction.

Details

This shows you the details of the transaction highlighted in the transaction list.

Account: The name of a general ledger account.

Sub Account: The name of a customer, vendor, or item account. Applies only when the value of the Account field is a control account.

Debit: The debit amount.

Credit: The credit amount.

Description: The description of the transaction detail.

Remark: Some remarks of the entry. For example, the cheque number of a payment, etc.

Command Buttons

Others→Print Preview: Click this button to preview the printout.

Others→Select Report Form: Click this button to bring up the Select Report Form dialog.

Print: Click this button to print the transactions.

Refresh: Click this button to refresh the data.

Close: Click this button to close the form.

9.6 Account Receivable Aging Report

This report shows you who are the customers that owe you money and how long they have owed it to you.

To view the account receivable aging report, select Report→AR Aging from either the menu or the tool bar and click on the Refresh button of the AR Aging Report window.

Below describes the selection fields and command buttons on the Account Receivable Aging Report form.
Selection Fields

As Of: The reference date on which the aging report is computed.

Summary

The summary shows you who are the customers that owe you money and how long they have owed it to you.

Customer: The name of the customer.

0 – 30 days: The amount this customer still owes you after 0 to 30 days has/have elapsed.

31 – 60 days: The amount this customer still owes you after 31 to 60 days have elapsed.

61 – 90 days: The amount this customer still owes you after 61 to 90 days have elapsed.

90 days: The amount this customer still owes you after more than 90 days have elapsed.

All: The total amount this customer owes you.

Details

The shows you a list of outstanding invoices of a particular customer divided into different aging periods. To view the invoice document, double click on the invoice itself or right click on the invoice and select the Source Document command.

Date: The date of the source document.

Due Date: The invoice’s due date. Applicable only when the source document is an invoice.

Customer: The name of the customer.

Source: The type of source document. This can be an invoice or a credit memo.

Ref: The reference number of the source document.

Total: The total amount involved.

Amount Due: The amount still outstanding.
Days: The number of days has elapsed starting from the source document’s date.

Command Buttons

Print→Summary: Click this button to print the summary report.

Print→Details: Click this button to print the detailed report.

Preview→Summary: Click this button to preview the printing of the summary report.

Preview→Details: Click this button to preview the printing of the detailed report.

Refresh: Click this button to regenerate the report.

Close: Click this button to close the form.

9.7 Account Payable Aging Report

This report shows you which vendors you owe money to and how long you have owed it to them.

To view the account payable aging report, select Report→AP Aging from either the menu or the tool bar and click on the Refresh button of the AP Aging Report window.

Below describes the components on the “Account Payable Aging Report” form.

Selection Fields

As Of: The reference date on which the aging report is computed.

Summary

The summary shows you which vendor you owe money to and how long you have owed it to them.

Vendor: The name of the vendor.

0 – 30 days: The amount you still owe this vendor after 0 to 30 days has/have elapsed.

31 – 60 days: The amount you still owe this vendor after 31 to 60 days have elapsed.
61 – 90 days: The amount you still owe this vendor after 61 to 90 days have elapsed.

90 days: The amount you still owe this vendor after more than 90 days have elapsed.

All: The total amount you owe this vendor.

Details

The shows you a list of outstanding invoices of a particular vendor divided into different aging periods. To view the invoice document, double click on the invoice itself or right click on the invoice and select the Source Document command.

Date: The date of the source document.

Due Date: The invoice’s due date. Applicable only when the source document is an invoice.

Vendor: The name of the vendor.

Source: The type of source document. This can be an invoice or a debit memo.

Ref: The reference number of the source document.

Total: The total amount involved.

Command Buttons

Print ➔ Summary: Click this button to print the summary report.

Print ➔ Details: Click this button to print the detailed report.

Preview ➔ Summary: Click this button to preview the printing of the summary report.

Preview ➔ Details: Click this button to preview the printing of the detailed report.

Refresh: Click this button to regenerate the report.

Close: Click this button to close the form.

9.8 Report Explorer

Report Explorer is powerful reporting tool that lets you design your own reports based on the data stored in OneStep. As you are able to access almost all the business transaction data OneStep has captured for you, you would be able to design all kind of management reports you may want. OneStep has already predefined 130+ reports in Report Explorer which you can use immediately.

To access the Report Explore, select Report ➔ Report Explore from either the menu or the tool bar

Below describes the various component on the Report Explorer window.
Buttons on the tool bar.

<table>
<thead>
<tr>
<th>Button</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Up One Level</td>
<td>![Up Arrow]</td>
<td>When a folder is selected, use this button to select the parent folder.</td>
</tr>
<tr>
<td>New Folder</td>
<td>![Folder]</td>
<td>Creates a new folder within the currently selected folder.</td>
</tr>
<tr>
<td>Print</td>
<td>![Print]</td>
<td>Prints the currently selected report.</td>
</tr>
<tr>
<td>Print Preview</td>
<td>![Print Preview]</td>
<td>Opens the currently selected report and displays it in the print preview window.</td>
</tr>
<tr>
<td>Delete</td>
<td>![Trash]</td>
<td>Sends the currently selected item or items to the recycle bin. If the items are already in the recycle bin, deletes them.</td>
</tr>
<tr>
<td>List</td>
<td>![List]</td>
<td>Sets the list to display in columns and show the item name only.</td>
</tr>
<tr>
<td>Details</td>
<td>![Details]</td>
<td>Shows one item per row, lists metadata about items: item type, item size and date last modified.</td>
</tr>
</tbody>
</table>

**To print or preview a report**: Select the report on the right pane and click on the print or preview button on the tool bar.

**To Edit the Report Layout**: Double click on the report which you want to edit on the right pane.
10 Administration

10.1 Company

OneStep lets you set up your company information using the company function in OneStep. To work with the company inform, select Admin→Company from either the menu or the tool bar.

Below describes the data fields and the command buttons on the Company record form.

Data Fields

**Name:** Your Company’s name.

**Address:** Your Company’s address.

**Ship To:** The address where you want your vendor to ship the goods you purchased to.

**Tax Reg No:** Your Company’s tax registration or ID number.

Command Buttons

Please refer to 'Working with OneStep, Record Form'.

10.2 Employee

OneStep lets you set up your employee information using the employee function in OneStep. To work with the employee inform, select Admin→Employees from either the menu or the tool bar

10.2.1 Employee List Form

Below describes the components pertaining to the Employee list form. Please refer to “Working with OneStep, List Form” for components not described here.
Data Fields

**Name**: The name of the employee.

**Initial**: The initial of the employee.

**Phone**: The employee’s phone number.

10.2.2 Employee Record Form

Below describes the components pertaining to the Employee record form. Please refer to “Working with OneStep, Record Form” for components not described here.

Data Fields

**Name**: The name of your employee.

**Initial**: A short name for this employee.

**Phone**: The phone number for this employee.

**Active**: Check this if you want this employee to appear in the sales representative selection.

10.3 Terms

You can set up credit terms information using the Terms function in OneStep. To work with credit terms, select Admin⇒Terms from either the menu or the tool bar.
10.3.1 Terms List Form

Below describes the components pertaining to the Terms list form. Please refer to “Working with OneStep, List Form” for components not described here.

Data Fields

**Name:** The name of the credit terms.

**Description:** The description of the credit terms.

10.3.2 Terms Record Form

Below describes the components pertaining to the Terms record form. Please refer to “Working with OneStep, Record Form” for components not described here.

Data Fields

**Name:** The name of the payment terms.

**Description:** The description of the payment terms.

**Type:** The type of payment terms. OneStep supports four different types of payment terms.

<table>
<thead>
<tr>
<th>Type</th>
<th>Used For</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cash On Delivery</td>
<td>Payment is collected immediately upon delivery.</td>
</tr>
</tbody>
</table>
Due in number of days  
Payment is due in number of days specified.

Due on day of month  
Payment is due on a specific date of this month.

Due on day of next month  
Payment is due on a specific date of next month.

**Discount %**: The percentage discount the debtor gets if he settle the payment before the discount date.

**Discount In**: The number of days by which payment must be received to qualify for the discount

**Discount By**: The date of the month by which payment must be received to qualify for the discount

**Net Due In**: The number of day in which the payment is due.

**Due On The**: The date on which the payment is due.

### 10.4 Payment Method

You can set up payment method information using the payment methods function in OneStep. To work with payment method, select Admin ➔ Payment Methods from either the menu or the tool bar.

#### 10.4.1 Payment Method List Form

Below describes the components pertaining to the Payment Method list form. Please refer to “Working with OneStep, List Form” for components not described here.

![Payment Methods List Form](image)

**Data Fields**

**Name**: The name of the payment method.

**Description**: The description of the payment method.

#### 10.4.2 Payment Method Record Form

Below describes the components pertaining to the Payment Method record form. Please refer to “Working with OneStep, Record Form” for components not described here.
Data Fields

**Name**: The name of the payment method.

**Description**: The description of the payment method.

**Default Posting Account**: The default posting account for this payment method.

### 10.5 User (Available In Professional Edition Only)

The user and user group functions in OneStep enables you to control the user access to all the functions in OneStep. To set up a user account in OneStep, select Admin → Users from either the menu or tool bar.

#### 10.5.1 User List Form

Below describes the components pertaining to the User list form. Please refer to “Working with OneStep, List Form” for components not described here.

**Data Fields**

- **User Id**: The user id of the user.
- **Name**: The name of the user.

#### 10.5.2 User Record Form

Below describes the components pertaining to the User record form. Please refer to “Working with OneStep, Record Form” for components not described here.

120 Administration
Data Fields

**User Id:** The user id of the user. When a user login to OneStep, he needs to enter the user id as well as the password.

**Name:** The name of the user.

**Super User:** Check this field if this is a super user. A super user in OneStep has the rights to perform any function and access any data in the system.

**Active:** When a user is inactive, he will be prohibited to login and to access any functions in OneStep.

**Remark:** Some comments on the user.

Under the 'Assign to Group' tab:

OneStep uses the concept of user group to assign access rights to a group of user. When you assign a user to a particular group, the user will be given all the access rights given to this particular group.

**Groups Available:** A list of the user groups available.

**Groups User Assigned To:** A list of user groups to which the user has been assigned.

Under the 'Additional Rights' tab:

You can use this tab page to add access rights to a user on top of assigning him to a user group.

**Item:** A list of items whose access is controlled by OneStep.

**Right:** A list of access rights associated with the item selected in the item list. Check the checkbox against the right to grant the user group the right to the associated function.

Under the 'Password' tab:

The tab page allows you to set or change the password of a particular user.

**Password:** Set the user password here.

**Verify Password:** Enter the user password again here to confirm the password set in the password field.
Command Buttons

Under the 'Additional Rights' tab

**Clear All**: To uncheck all the rights in the list.

**Select All**: To check all the rights in the list.

10.6 **User Group (Available In Professional Edition Only)**

OneStep allows you to assign access rights to a group of users using the user group. To work with user group, select Admin → User Group from the menu or the toolbar.

10.6.1 **User Group List Form**

Below describes the components pertaining to the User Group list form. Please refer to “Working with OneStep, List Form” for components not described here.

![User Group List Form](image)

**Data Fields**

**Name**: The name of the user group.

10.6.2 **User Group Record Form**

Below describes the components pertaining to the User Group record form. Please refer to “Working with OneStep, Record Form” for components not described here.
Date Fields

**Name**: The name of the user group.

**Description**: The description of the user group.

**Item**: A list of items whose access is controlled by OneStep.

**Right**: A list of access rights associated with the item selected in the item list. Check the checkbox against the right to grant the user group the right to the associated function.

Command Buttons

**Clear All**: To uncheck all the rights in the list.

**Select All**: To check all the rights in the list.

### 10.7 Preference

There are a number of system preferences that you need to set up before starting out with OneStep. To set up these parameters, select Administration⇒Preference from the menu bar. The Preferences function also lets you set up values that are frequently used so that these values would appear as the default values wherever they are needed.

Below describes the data fields and the command buttons on the Preference form.
Data Fields

Under the 'System / General' tab:

**Use Audit Trail**: Check this if you want OneStep to keep track of the changes made to a transaction.

**Allow Inventory To Go Negative**: Check this if you want OneStep to allow the quantity value of an item to go negative.

**Sales Price Table**: This field lets you set the sales price table to use for customized pricing.

Under the 'System / Posting Account' tab:

**Retained Earnings Account**: The general ledger account designated as the retained earnings account.

Under the 'Frequently Used Values / General' tab:

**Payment Method**: The payment method that is frequently used.

**Early Payment Discount Account for Sales**: The general ledger account to which the discount for early payment for sales is posted.

**Early Payment Discount Account for Purchase**: The general ledger account to which the discount for early payment for purchase is posted.

Under the 'Frequently Used Values / Item' tab:

**Sales Account**: The general ledger account to which sales amount is posted.

**Sales Return Account**: The general ledger account to which sales return amount is posted.

**Purchase Account**: The general ledger account to which purchase for non-inventory item and services are posted.

**Control Account**: The default control account when creating a new item account.

**Cost of Goods Sold Account**: The general ledger account to which the cost of goods sold amount is posted.

**Cost Method**: The default cost method when creating a new item account.

Under the 'Frequently Used Values / Customer' tab:

**Control Account**: The default control account used when adding a new customer account.

**Terms**: The default payment terms used when adding a new customer account.

**Credit Limit**: The default credit limit used when adding a new customer account.

**Tax Items**: The default tax items used when adding a new customer account.

**Calc. Tax After Discount**: Check this if you want to calculate the tax amount based on the total amount less early payment discount

Under the 'Frequently Used Values / Vendor' tab:

**Control Account**: The default control account used when creating a new vendor account.

**Terms**: The default payment terms used when creating a new vendor account.
Credit Limit: The default credit limit used when creating a new vendor account.

Tax Items: The default tax items used when creating a new vendor account.

Calc. Tax After Discount: Check this if you want to calculate the tax amount based on the total amount less early payment discount

Command Buttons

Please refer to “Working with OneStep, Record Form”.

10.8 Document Reference

OneStep lets you set up how you want it to generate reference numbers. All generated reference numbers have a format as follow.

Prefix + Running Number + Suffix

To set up the reference number, select Preference → Document Preferences from the menu bar.

Below describes the data fields and the command buttons on the Document Preferences form.

Data Fields

Document: The name of the document.
Prefix: The prefix string.
Last No: The last-used running number.
Digits: The minimum number of digits for the running number. '0' will be padded in front of the running number where necessary.
Suffix: The suffix string.

Command Buttons

Please refer to “Working with OneStep, Record Form”.

Administration 125
10.9 Data Protection (Available In Professional Edition Only)

You can protect the documents you have entered into the system using a protection date. With this protection, users who do not have the right to modify protected documents are not allowed to add, edit and delete the documents whose document date is on or before the protection date.

OneStep allows you to divide documents into different protection groups (max. 3 groups) and assign each group with a different protection date. To set up the protection dates, Select Admin ➔ Data Protection from the menu bar.

Below describe the data fields and the command buttons on the Data Protection form.

Data Fields

A: The protection date for documents assigned to categories A.
B: The protection date for documents assigned to categories B.
C: The protection date for documents assigned to categories C.

Document: The name of the document.
Category: The category to which the associated document is assigned.

Command Buttons

Please refer to “Working with OneStep, Record Form”.

10.10 Freeze Data

In addition to the data protection function, OneStep also allows you to set a freeze date, such that no one can modify those documents entered on or before this date. To set the freeze date, select Admin ➔ Freeze Date from the menu bar.

Below shows the dialog box that prompts you for a new freeze date when you click on the Freeze Date command.
**Prevailing Freeze Date:** The freeze date that is currently used by the system.

**New Freeze Date:** Enter a new date here to change the freeze date. You can enter a date before or after the prevailing freeze date.

### 10.11 Year End Closing

At the end of the year, very often you will need to compute the profits (or losses) you made in the year and also to reset the income and expense accounts to zero balance. The year-end-closing function in OneStep does exactly that for you. It generates a general journal entry that zeros the balances for your profit and loss statement’s accounts, i.e., closes all your income, cost of sales, expense, other income and other expense accounts and transfers the profit or loss to the retained earnings account.

To run the year-end closing function, select Admin ➔ Year End Closing from the menu bar.

Below shows the dialog box that prompts you for a closing date when you click on the Year-End Closing function.

![Closing Date Dialog Box](image)

**Closing Date:** Specify the year-end closing date here.

**GJ No:** The reference number of the general journal entry that the closing function is going to generate. If this field is left blank, OneStep will automatically fill it with the next GJ number.

### 10.12 Condense Data

When you find that some of the historical data in OneStep are too old and are no longer needed for future reference, you can use the Condense Data function to remove these data and save you some disk space. What OneStep does is to consolidate all transactions on and before the date you specify and substitute them with one GJ entry and one inventory adjustment. Be aware that this function will remove all data before the specified date and you will no longer be able to access these data.

To perform the Condense Data function, select Admin ➔ Condense Data.

Below shows the dialog box that prompts you for a cut off date when you click on the Condense Data function.

![Condense Data Dialog Box](image)

**Condense Data On and Before Date:** Enter the date on and before which all the transactions are be condensed.

**GJ No:** The reference number of the general journal entry that the Condense Data function is going to generate. If this field is left blank, OneStep will automatically fill it with the next GJ number.
**Inventory Adj No:** The reference number of the inventory adjustment entry that the Condense Data function is going to generate. If this field is left blank, OneStep will automatically fill it with the next Inventory Adjustment number.

### 10.13 Purge Transaction History

If you make any changes to a transaction with the Use Audit Trail in Preferences turned on, the details of the old transaction will be kept by the system so as to maintain a trail on the changes to the transaction. To remove this trail, you can use the purge transaction history function.

Below shows the dialog box that prompts you for a cut off date when you click on the Purge Transaction History function.

![Purge Transactions History](image)

Purge Transaction History On and Before: Enter the date on and before which all the transaction history are to be purged.
11 Others

11.1 Login

Before you can access the data and functions in OneStep, you need to first log in to the system. To log in to the system, select File→Login from the menu bar.

Below shows the dialog box you will see when you run function.

![Login dialog box]

User Id: Enter your user id here.

Password: Enter your password here.

11.2 Logout

To log off from OneStep, select File→Logout from the menu bar. Once you have logged off, you have to log in again in order to access the data and functions in OneStep.

11.3 Change Password

You can change your password by using the Change Password function. To change password, select File→Change Password from the menu bar.

Below shows the dialog box you will see when you run function.

![Change Password dialog box]

Old Password: Enter your existing password here.

New Password: Enter the new password that you want to change to here.

Verify Password: Enter you new password again.

11.4 Create a New Company

To create a new data file for your company, select File→New Company from the menu bar.
When prompted, enter a name for the data file (for example, c:\enable computing\onestep\data\abc, assuming abc is your company name) where your company's data will be stored and click Ok.

After the new company has been created, select File→Login to log in. The user id to use is super with no password.

11.5 Open an Existing Company

To open the data file of an existing company, select File→Open Company from the menu bar. When prompted, select the data file you want and click Open.

11.6 Backup Data

It is important to backup your data on a regular basis so that in case your data is accidentally deleted or corrupted, you will have the backup to restore them.

To backup your data in OneStep, select File→Backup from the menu bar.
When prompt, either use the system generated file name or enter a file name at the File Name field and click on the Open button. Your should try to save your backup file to a secondary storage (e.g. Your zip drive or cdrom), so that in the event that you hard disk is giving you problem you would be able to restore the data file from your secondary storage.

11.7 Restore Data

To restore your data from a backup file, select File→Restore from the menu bar.

When prompt, enter the file name of your last backup file at the From field and a file name for the to be restored file at the Restore To field and click on the Ok button.
12 Transaction Examples

This chapter shows some examples of the common transactions in OneStep.

12.1 Invoicing Your Customers

Below shows the steps on how you can create an invoice to bill your customer for products delivered or services rendered,

1. Select Sales→Invoices from either the menu or the tool bar.

2. Click on the New button in the Sales Invoice List Form.

3. Click on the Customer Account drop-down box to select a customer.

4. Click on the Date drop-down box to select the invoice date.

5. Click on the Terms drop-down box to select the credit terms.

6. Click on the Item drop-down box to select the product or service that you are billing for.

7. Tab to the Qty column, and enter the quantity value.

8. To add another item, either press the Down Arrow key to go to the next line or press the Tab key to move past the last column to go to the next line.

9. To delete an item, press Ctrl+Del (i.e. Pressing the Ctrl and Del keys together).

10. Repeat Step 6 to 8 until all the items to be invoiced are entered.

11. Click on the Ok button to save the invoice or the Print button to save and print the invoice.

12.2 Recording Payments From Customers

Below shows the steps on how you can record a payment from your customer for one or more invoices.

1. Select Cash→Receipts from either the menu or the tool bar.

2. Click on the New button in the Cash Receipt List Form.

3. Select Customer as the From value to indicate that the payment is from a customer.

4. Click on the Date drop-down box to select the receipt date.
5. Click on the Account drop-down box to select the customer account from whom the payment is received.

6. Enter the amount received.

7. Click on the Pmt Method drop-down box to indicate the payment method.

8. If the payment is made by cheque, enter the cheque number in the Pmt Ref field.

9. Click on the Add button to bring up the Open Invoices and Credit Memos dialog.

10. Select the invoice(s) against which the payment is made and click on the add button from the Open Invoices and Credit Memos dialog to add the invoice(s) to the Cash Receipt.

11. Click on the D checkbox if early payment discount is given for the invoice. Alternatively, you can key in the discount amount directly into the discount column.

12. Click on the P checkbox to let OneStep fills in the payment amount for the invoice for you. Alternatively, you can key in the payment amount directly into the payment column.

13. Click on the Ok button to save the receipt.

Please note:

a) When an invoice amount is fully paid, OneStep will automatically set the invoice to Closed.

b) If the receipt's amount is equal to the sum of the payment amounts of all the invoices and credit memos in the receipt, the Closed status of the receipt is automatically set.

### 12.3 Recording Bills From Vendors

Below shows the steps on how you can record a bill from your vendor.

1. Select Purchase→Invoices from either the menu or the tool bar.

2. Click on the New button in the Sales Invoice List Form.
3. Click on the Vendor Account drop-down box to select a vendor.

4. Click on the Date drop-down box to select the invoice date.

5. Enter the invoice reference number.

6. Click on the Terms drop-down box to select the credit terms.

7. Click on the Item drop-down box to select the product or service that you are billed for.

8. Tab to the Qty column, and enter the quantity value.

9. Tab to the Unit Price column, and enter the unit price of the item if it is different from the default.

10. To add another item, either press the Down Arrow key to go to the next line or press the Tab key to move past the last column to go to the next line.

11. To delete an item, press Ctrl+Del (i.e. Pressing the Ctrl and Del keys together).

12. Repeat Step 7 to 10 until all the items are entered.

13. Click on the Ok button to save the invoice.

12.4 Recording Payments To Vendors

Below shows the steps on how you can record a payment to your vendor for one or more invoices.

1. Select Cash ➔ Disbursements from either the menu or the tool bar.

2. Click on the New button in the Cash Disbursement List Form.

3. Select Vendor as the To value to indicate that the payment is made to a vendor.
4. Click on the Date drop-down box to select the disbursement date.
5. Click on the Account drop-down box to select the vendor account to whom the payment is made.
6. Enter the amount paid.
7. Click on the Pmt Method drop-down box to indicate the payment method.
8. If the payment is made by cheque, enter the cheque number in the Pmt Ref field.
9. Click on the Add button to bring up the Open Invoices and Debit Memos dialog.
10. Select the invoice(s) against which the payment is made and click on the add button from the Open Invoices and Debit Memos dialog to add the invoice(s) to the Cash Disbursement.
11. Click on the D checkbox if early payment discount is given for the invoice. Alternatively, you can key in the discount amount directly into the discount column.
12. Click on the P checkbox to let OneStep fills in the payment amount for the invoice for you. Alternatively, you can key in the payment amount directly into the payment column.
13. Repeat Step 11 to 12 until the discount and payment amounts for all the selected invoices are entered.
14. Click on the Ok button to save the disbursement.
15. Additionally, you can print a remittance advice or print a cheque using the Others → Select Report Form function.

Please note:

a) In order for OneStep to print your cheque correctly, you would need to use the Report Designer to customize the layout of the cheque printing report form.

b) When an invoice amount is fully paid, OneStep will automatically set the invoice to Closed.

c) If the disbursement's amount is equal to the sum of the payment amounts of all the invoices and debit memos in the disbursement, the Closed status of the disbursement is automatically set.

12.5 Recording Expenses

Below shows the steps on how you can record an expense claim from one of your employees.

1. Select Cash → Disbursements from either the menu or the tool bar.
2. Click on the New button in the Cash Disbursement List Form.
3. Select Others as the To value.
4. Click on the Date drop-down box to select the disbursement date.
5. Enter the total amount of the claim.
6. Click on the Pmt Method drop-down box to indicate the payment method.

7. If the payment is made by cheque, enter the cheque number in the Pmt Ref field.

8. Enter the employee name to the Pay To field.

9. Enter a description for the payment.

For each claim item,

10. Under the distribution, select the account to charge.

11. Enter a description for the claim.

12. Enter the amount of the claim. If the claim includes a tax amount and you want to claim input tax on the tax amount, you would enter the amount as the total claim amount less the tax amount. In our example, the total handphone bill was $315. However, because there a $15 tax amount, we would split the claim into two rows, one for recording the Phone & Fax expense ($300) and one for recording the tax amount ($15).

13. Tab to the Tax column to select the tax item if you are recording a tax amount.

14. Tab to the Tax Type column to select the tax type if you are recording a tax amount.

15. Edit the taxable total if necessary when you are recording a tax amount.

16. Repeat Step 10 to 15 until all the claim items are entered.

17. Click on the Ok button to save the disbursement.

18. Additionally, you can print a payment voucher or print a cheque using the Others ➔ Select Report Form function.

Please note:

a) In order for OneStep to print your cheque correctly, you would need to use the Report Designer to customize the layout of the cheque printing report form.

12.6 Recording Inventory Adjustments

Below shows the steps on how you can record an inventory adjustment for damaged stock items.

1. Select Item ➔ Inventory Adjustments from either the menu or the tool bar.

2. Click on the New button in the Inventory Adjustment List Form.

3. Click on the Date drop-down box to select the date for the inventory adjustment.

4. Enter a description for the inventory adjustment.

136 Transaction Examples
5. Click on the Adjustment Account drop-down box to select the account to which the inventory adjustment amount should be posted.

6. Click on the Item drop-down box to select the inventory product that you to adjust for.

7. Tab to the Qty field to enter the quantity to be adjusted. Enter a positive value to increase the on-hand quantity of the item else enter a negative value to decrease the on-hand quantity of the item.

8. Tab to the Cost Of Good field to enter the dollar amount of the adjusted items. If you are increasing the on-hand quantity of the item, you have to provide this value. If you are reducing the on-hand quantity of the item, you can either leave the field as zero dollar or fill in a value. If you leave it as zero dollar, OneStep will use the cost method of the item to decrease its inventory amount. If you fill in a value, OneStep will use the provided amount to decrease its inventory amount. In our example, we leave this field as zero dollar so that OneStep will base on the selected cost method for this item to calculate the inventory cost for us.

9. Repeat Step 6 to 8 until all the items to be adjusted are entered.

10. Click on the Ok button to save the inventory adjustment.
Appendix A: Business Documents, Transactions and Accounts

Each day in the life of a business, sales orders are received, purchase orders are sent, goods and services are purchased and sold, credits are extended to customers, debts are incurred and cash is received and paid out. Each of these activities must be recorded and tracked. Some of these activities have direct bearing on the financial positions of a business. When cash is paid out, the cash-on-hand of a business is decreased or when a sale is made, the various records for keeping track of the accumulated sales, sales tax, customer credit amounts, etc are increased or decreased.

OneStep identifies these activities and captures the processing of these activities using three components.

Business Documents

Business documents are used to record the occurrences the business activities. For example, when a credit sale is made, a document called the sales invoice is created to record the sale.

Transactions

For any business activity that involves a change in the financial position of a business, a transaction record captures the changes. For example, when a credit sale is made, changes to the customer accounts, the sales account, the sales tax account, the inventory account and the cost of goods sold account are captured in a transaction record.

Accounts

Accounts are the records that keep track of the accumulated effects of all the transactions have on the financial positions of a business.

The diagram below depicts the relationship of these components.
Appendix B: Security

It is very important that you protect your data from illegal access from unauthorized persons. In OneStep, there are several levels of protection to help you prevent for illegal access.

User Access Security

Before anyone can access the data or run any functions in OneStep, he needs to first log on to OneStep. In OneStep, what a user is allowed to access is restricted by the access rights granted to him or her. You can use the User and User Group functions in OneStep to grant access rights to a user or a group of user.

Data Access Protection

Almost all the data in OneStep are protected by four types of access rights, that is, the View, Add, Update and Delete rights. The View access right gives the users the right to view the data, the Add access right gives the users the right to add new data, the Update access right gives the users the right to Update the data and the Delete access right gives the user the right to delete the data.

Function Access Protection

Many functions in OneStep are protected by the access right to run the function. For example, for a user to run a trial balance report, he must be first granted with the right to run it.

Date Protection

On top of the data access protection, OneStep also allows you to protect your business documents (like the sales orders, invoices, cash receipts, etc) using a protection date. With a protection date, documents dated on or before the protection date are protected and only user with the appropriate right to update date protected documents can modify them. Please see the “Administration, Data Protection” section for more information.

Freeze Date Protection

After you have generated your financial reports and you do not want anyone to make changes to the data constituted to these reports, you can use the Freeze Date function in OneStep to protect these data. The Freeze Date function prevents anyone from changing those business documents dated on or before the freeze date. Please see the “Administration, Freeze Date” section for more information.
Appendix C: Using OneStep as a Point of Sales system

You can turn OneStep Accounting into a Point of Sales system by connecting your PC with a cash drawer and a receipt printer.

OneStep lets you control the opening and closing of the cash drawer of the cutting of the paper on a receipt printer using some key values defined in the window registry. You can find these keys under HKEY_LOCAL_MACHINE\Software\Enable Computing\OneStep\4.0\Cash Sales and the values you can defined are:

**Before Print Device**: Enter the device name to which the “Before Print” string should be sent.

**Before Print**: Enter the string to be sent before the actual printing of a receipt. Usually used for sending the control codes to open the cash drawer.

**After Print Device**: Enter the device name to which the “After Print” string should be sent.

**After Print**: Enter the string to be sent after the actual printing of a receipt. Usually used for sending the control codes to cut the receipt’s paper.

**POS**: Enter “T” to use a simplified cash sales screen tailored for a Point of Sale. When in simplified mode, you are able to move out from the line item’s table to the 'Pay To' field by pressing the F12 key.

Just to give you an example, if you are using Citizen idp-3541 impact printer and a compatible cash drawer you can set the keys as follows:

- Before Print Device: LPT1
- Before Print: 28
- After Print Device: LPT1
- After Print: 27,80,00
- POS: T
Appendix D: Switching To Professional Edition From Standard Edition

Appendix E: Documents’ Abbreviations

Below is a list of the types of documents in OneStep and their abbreviations.

<table>
<thead>
<tr>
<th>Document</th>
<th>Abbreviation</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Journal</td>
<td>GJ</td>
</tr>
<tr>
<td>Sales Invoice</td>
<td>SI</td>
</tr>
<tr>
<td>Purchase Invoice</td>
<td>PI</td>
</tr>
<tr>
<td>Cash Receipt</td>
<td>RE</td>
</tr>
<tr>
<td>Cash Disbursement</td>
<td>DI</td>
</tr>
<tr>
<td>Cash Sales</td>
<td>CS</td>
</tr>
<tr>
<td>Credit Memo</td>
<td>CM</td>
</tr>
<tr>
<td>Cash Purchase</td>
<td>CP</td>
</tr>
<tr>
<td>Debit Memo</td>
<td>DM</td>
</tr>
<tr>
<td>Sales Order</td>
<td>SO</td>
</tr>
<tr>
<td>Purchase Order</td>
<td>PO</td>
</tr>
<tr>
<td>Inventory Adjustment</td>
<td>IA</td>
</tr>
<tr>
<td>Build Assembly</td>
<td>BA</td>
</tr>
<tr>
<td>Sales Quotation</td>
<td>SQ</td>
</tr>
<tr>
<td>Delivery Order</td>
<td>DO</td>
</tr>
<tr>
<td>Goods Received Note</td>
<td>GRN</td>
</tr>
</tbody>
</table>